Skip to content

MikroTik を L3SW ライクに Access / Trunk ポートを設定する

MikroTik を L3SW のように設定した際のコンフィグをメモしておきます。具体的には MikroTik に VLAN を設定し、ダウンリンク側はアクセスポート、アップリンク側はトランクポートとして設定します。

検証環境

以下の構成で検証を実施しました。

file

左側の 2 は「CRS109」を、右側の 3 は「CCR1009」を使いました。OS は両者ともに 6.37.3 を使用しました。

2 のコンフィグ

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
/interface bridge
add name=bridge1 protocol-mode=none

/interface vlan
add interface=ether3 loop-protect-disable-time=0s loop-protect-send-interval=0s name=vlan100-ether3 vlan-id=100

/interface bonding
add mode=802.3ad name=bonding1 slaves=ether5,ether6 transmit-hash-policy=layer-2-and-3

/interface vlan
add interface=bonding1 loop-protect-disable-time=0s loop-protect-send-interval=0s name=vlan200-bonding1 vlan-id=200

/interface bridge port
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=vlan100-ether3

/ip address
add address=192.168.12.2/24 interface=vlan100-ether3 network=192.168.12.0
add address=192.168.23.2/24 interface=vlan200-bonding1 network=192.168.23.0

/ip route
add distance=1 dst-address=192.168.34.0/24 gateway=192.168.23.3

/system identity
set name=MikroTik1

3 のコンフィグ

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
/interface bridge
add name=bridge1 protocol-mode=none

/interface vlan
add interface=ether3 loop-protect-disable-time=0s loop-protect-send-interval=0s name=vlan300-ether3 vlan-id=300

/interface bonding
add mode=802.3ad name=bonding1 slaves=ether5,ether6 transmit-hash-policy=layer-2-and-3

/interface vlan
add interface=bonding1 loop-protect-disable-time=0s loop-protect-send-interval=0s name=vlan200-bonding1 vlan-id=200

/interface bridge port
add bridge=bridge1 interface=vlan300-ether3
add bridge=bridge1 interface=ether3

/ip address
add address=192.168.23.3/24 interface=vlan200-bonding1 network=192.168.23.0
add address=192.168.34.3/24 interface=vlan300-ether3 network=192.168.34.0

/ip route
add distance=1 dst-address=192.168.12.0/24 gateway=192.168.23.2

/system identity
set name=MikroTik2

参考

下記は MikroTik 公式の、VLAN 設定例です。但し、MikroTik を L2SW として設定しています。