Skip to content

IOSv でマルチキャストを設定する (Static RP)

CML 上の IOSv で Static RP 構成でマルチキャストを設定したサンプルコンフィグをメモしておきます。 尚、CML へインポート可能な構成ファイルは GitHub にアップロードしてあります。

構成

IOSv1 は Source、IOSv5 は Receiver として設定します。 IOSv2 ~ 4 では OSPF を動作させ、全てのユニキャストルーティングが出来るように設定します。 IOSv3 は RP (Rendezvous Point) として設定します。

file

コンフィグ

中継区間となる IOSv2 ~ 4 の全てのインターフェイスには ip pim sparse-mode を設定します。 また、今回は Static RP を利用するので IOSv2 ~ 4 には ip pim rp-address [RP-ADDRESSS] を設定します。

IOSv1

Source になる IOSv1 は no ip routing でルーティングを無効化し、ip default-gateway [ADDRESS] でデフォルトゲートウェイだけ、設定しています。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
hostname IOSv1
!
no service config
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
!
logging buffered 65536 debugging
!
clock timezone JST +9
!
no ip routing
!
no ip domain-lookup
!
interface GigabitEthernet0/0
 ip address 10.0.12.1 255.255.255.0
 no shutdown
!
ip default-gateway 10.0.12.2
!
line con 0
 exec-timeout 60 0
 privilege level 15
!
scheduler allocate 20000 1000
!
no banner exec ^C
no banner incoming ^C
no banner login ^C

IOSv2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
hostname IOSv2
!
no service config
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
!
logging buffered 65536 debugging
!
clock timezone JST +9
!
no ip domain-lookup
!
ip multicast-routing
!
interface GigabitEthernet0/0
 ip address 10.0.12.2 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
interface GigabitEthernet0/1
 ip address 10.0.23.2 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
interface GigabitEthernet0/3
 ip address 10.0.24.2 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
router ospf 65000
 router-id 10.2.2.2
 passive-interface GigabitEthernet0/0
 network 10.0.12.0 0.0.0.255 area 0.0.0.0
 network 10.0.23.0 0.0.0.255 area 0.0.0.0
 network 10.0.24.0 0.0.0.255 area 0.0.0.0
!
ip pim rp-address 10.3.3.3
!
line con 0
 exec-timeout 60 0
 privilege level 15
!
scheduler allocate 20000 1000
!
no banner exec ^C
no banner incoming ^C
no banner login ^C

IOSv3

RP として動作させるので Loopback インターフェイスを設定します。 Loopback インターフェイスにも忘れずに ip pim sparse-mode を設定します。 また、ip pim rp-address 10.3.3.3 と自身の Loopback アドレスを指定して Static RP 設定を実施しておきます。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
hostname IOSv3
!
no service config
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
!
logging buffered 65536 debugging
!
clock timezone JST +9
!
no ip domain-lookup
!
ip multicast-routing
!
interface Loopback0
 ip address 10.3.3.3 255.255.255.255
 ip pim sparse-mode
!
interface GigabitEthernet0/1
 ip address 10.0.23.3 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
interface GigabitEthernet0/2
 ip address 10.0.34.3 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
router ospf 65000
 router-id 10.3.3.3
 network 10.3.3.3 0.0.0.0 area 0.0.0.0
 network 10.0.23.0 0.0.0.255 area 0.0.0.0
 network 10.0.34.0 0.0.0.255 area 0.0.0.0
!
ip pim rp-address 10.3.3.3
!
line con 0
 exec-timeout 60 0
 privilege level 15
!
scheduler allocate 20000 1000
!
no banner exec ^C
no banner incoming ^C
no banner login ^C

IOSv4

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
hostname IOSv4
!
no service config
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
!
logging buffered 65536 debugging
!
clock timezone JST +9
!
no ip domain-lookup
!
ip multicast-routing
!
interface GigabitEthernet0/2
 ip address 10.0.34.4 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
interface GigabitEthernet0/3
 ip address 10.0.24.4 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
interface GigabitEthernet0/4
 ip address 10.0.45.4 255.255.255.0
 ip pim sparse-mode
 no shutdown
!
router ospf 65000
 router-id 10.4.4.4
 passive-interface GigabitEthernet0/0
 network 10.0.24.0 0.0.0.255 area 0.0.0.0
 network 10.0.34.0 0.0.0.255 area 0.0.0.0
 network 10.0.45.0 0.0.0.255 area 0.0.0.0
!
ip pim rp-address 10.3.3.3
ip pim spt-threshold infinity
!
line con 0
 exec-timeout 60 0
 privilege level 15
!
scheduler allocate 20000 1000
!
no banner exec ^C
no banner incoming ^C
no banner login ^C

IOSv5

Receiver になる IOSv5 は Source となる IOSv1 同様、no ip routing でルーティングを無効化し、ip default-gateway [ADDRESS] でデフォルトゲートウェイだけ、設定しています。 マルチキャストの Receiver として動作させる為に ip igmp join-group [MCAST-ADDR] でマルチキャストグループに参加します。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
hostname IOSv5
!
no service config
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
!
logging buffered 65536 debugging
!
clock timezone JST +9
!
no ip routing
!
no ip domain-lookup
!
interface GigabitEthernet0/4
 ip address 10.0.45.5 255.255.255.0
 ip igmp join-group 224.1.1.1
 no shutdown
!
ip default-gateway 10.0.45.4
!
line con 0
 exec-timeout 60 0
 privilege level 15
!
scheduler allocate 20000 1000
!
no banner exec ^C
no banner incoming ^C
no banner login ^C

状態確認

1. show ip pim interface

IOSv1

1
2
3
4
IOSv1# show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR         DR
                                          Mode   Count  Intvl  Prior

IOSv2

1
2
3
4
5
6
7
IOSv2# show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR         DR
                                          Mode   Count  Intvl  Prior
10.0.12.2        GigabitEthernet0/0       v2/S   0      30     1          10.0.12.2
10.0.23.2        GigabitEthernet0/1       v2/S   1      30     1          10.0.23.3
10.0.24.2        GigabitEthernet0/3       v2/S   1      30     1          10.0.24.4

IOSv3

1
2
3
4
5
6
7
IOSv3# show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR         DR
                                          Mode   Count  Intvl  Prior
10.3.3.3         Loopback0                v2/S   0      30     1          10.3.3.3
10.0.23.3        GigabitEthernet0/1       v2/S   1      30     1          10.0.23.3
10.0.34.3        GigabitEthernet0/2       v2/S   1      30     1          10.0.34.4

IOSv4

1
2
3
4
5
6
7
IOSv4# show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR         DR
                                          Mode   Count  Intvl  Prior
10.0.34.4        GigabitEthernet0/2       v2/S   1      30     1          10.0.34.4
10.0.24.4        GigabitEthernet0/3       v2/S   1      30     1          10.0.24.4
10.0.45.4        GigabitEthernet0/4       v2/S   0      30     1          10.0.45.4

IOSv5

1
2
3
4
IOSv5# show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR         DR
                                          Mode   Count  Intvl  Prior

2. show ip pim neighbor

IOSv1

1
2
3
4
5
6
7
IOSv1# show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable,
      L - DR Load-balancing Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode

IOSv2

1
2
3
4
5
6
7
8
9
IOSv2# show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable,
      L - DR Load-balancing Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.0.23.3         GigabitEthernet0/1       00:04:56/00:01:23 v2    1 / DR S P G
10.0.24.4         GigabitEthernet0/3       00:04:56/00:01:20 v2    1 / DR S P G

IOSv3

1
2
3
4
5
6
7
8
9
IOSv3# show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable,
      L - DR Load-balancing Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.0.23.2         GigabitEthernet0/1       00:04:46/00:01:43 v2    1 / S P G
10.0.34.4         GigabitEthernet0/2       00:04:46/00:01:19 v2    1 / DR S P G

IOSv4

1
2
3
4
5
6
7
8
9
IOSv4# show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable,
      L - DR Load-balancing Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.0.34.3         GigabitEthernet0/2       00:04:51/00:01:23 v2    1 / S P G
10.0.24.2         GigabitEthernet0/3       00:04:50/00:01:42 v2    1 / S P G

IOSv5

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
IOSv5# show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR         DR
                                          Mode   Count  Intvl  Prior
IOSv5#
IOSv5# show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable,
      L - DR Load-balancing Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode

3. show ip pim rp mapping

IOSv1

1
2
IOSv1# show ip pim rp mapping
PIM Group-to-RP Mappings

IOSv2

1
2
3
4
5
IOSv2# show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static
    RP: 10.3.3.3 (?)

IOSv3

1
2
3
4
5
IOSv3# show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static
    RP: 10.3.3.3 (?)

IOSv4

1
2
3
4
5
IOSv4# show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static
    RP: 10.3.3.3 (?)

IOSv5

1
2
IOSv5# show ip pim rp mapping
PIM Group-to-RP Mappings

4. show ip rpf

IOSv1

1
2
IOSv1# show ip rpf 10.0.12.1
 failed, no PIM enabled interfaces

IOSv2

1
2
3
4
5
6
7
8
IOSv2# show ip rpf 10.0.12.1
RPF information for ? (10.0.12.1)
  RPF interface: GigabitEthernet0/0
  RPF neighbor: ? (10.0.12.1) - directly connected
  RPF route/mask: 10.0.12.0/24
  RPF type: multicast (connected)
  Doing distance-preferred lookups across tables
  RPF topology: ipv4 multicast base

IOSv3

1
2
3
4
5
6
7
8
IOSv3# show ip rpf 10.0.12.1
RPF information for ? (10.0.12.1)
  RPF interface: GigabitEthernet0/1
  RPF neighbor: ? (10.0.23.2)
  RPF route/mask: 10.0.12.0/24
  RPF type: unicast (ospf 65000)
  Doing distance-preferred lookups across tables
  RPF topology: ipv4 multicast base, originated from ipv4 unicast base

IOSv4

1
2
3
4
5
6
7
8
IOSv4# show ip rpf 10.0.12.1
RPF information for ? (10.0.12.1)
  RPF interface: GigabitEthernet0/3
  RPF neighbor: ? (10.0.24.2)
  RPF route/mask: 10.0.12.0/24
  RPF type: unicast (ospf 65000)
  Doing distance-preferred lookups across tables
  RPF topology: ipv4 multicast base, originated from ipv4 unicast base

IOSv5

1
2
IOSv5# show ip rpf 10.0.12.1
 failed, no PIM enabled interfaces

5. show ip mroute

IOSv1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
IOSv1# show ip mroute
IP Multicast Forwarding is not enabled.
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

IOSv2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
IOSv2# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:08:27/00:02:38, RP 10.3.3.3, flags: SJCL
  Incoming interface: GigabitEthernet0/1, RPF nbr 10.0.23.3
  Outgoing interface list:
    GigabitEthernet0/0, Forward/Sparse, 00:08:26/00:02:38

IOSv3

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
IOSv3# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:07:22/00:03:00, RP 10.3.3.3, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet0/2, Forward/Sparse, 00:07:22/00:03:00

(*, 224.0.1.40), 00:08:17/00:02:58, RP 10.3.3.3, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet0/2, Forward/Sparse, 00:07:22/00:02:58
    GigabitEthernet0/1, Forward/Sparse, 00:07:26/00:02:53
    Loopback0, Forward/Sparse, 00:08:15/00:02:47

IOSv4

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
IOSv4# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:08:23/00:02:40, RP 10.3.3.3, flags: SC
  Incoming interface: GigabitEthernet0/2, RPF nbr 10.0.34.3
  Outgoing interface list:
    GigabitEthernet0/4, Forward/Sparse, 00:08:22/00:02:40

(*, 224.0.1.40), 00:08:23/00:02:49, RP 10.3.3.3, flags: SPCL
  Incoming interface: GigabitEthernet0/2, RPF nbr 10.0.34.3
  Outgoing interface list: Null

IOSv5

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
IOSv5# show ip mroute
IP Multicast Forwarding is not enabled.
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

6. 通信確認

IOSv1

Source である IOSv1 からマルチキャストグループ宛に Ping を実施し、Receiver から応答があることを確認します。

1
2
3
4
5
6
7
8
IOSv1# ping 224.1.1.1 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:
.
Reply to request 1 from 10.0.45.5, 37 ms
Reply to request 2 from 10.0.45.5, 12 ms
Reply to request 3 from 10.0.45.5, 12 ms
Reply to request 4 from 10.0.45.5, 12 ms

7. show ip mroute

file

IOSv1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
IOSv1# show ip mroute
IP Multicast Forwarding is not enabled.
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

IOSv2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
IOSv2# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:00:31/stopped, RP 10.3.3.3, flags: SPF
  Incoming interface: GigabitEthernet0/1, RPF nbr 10.0.23.3
  Outgoing interface list: Null

(10.0.12.1, 224.1.1.1), 00:00:31/00:03:02, flags: FT
  Incoming interface: GigabitEthernet0/0, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet0/1, Forward/Sparse, 00:00:31/00:03:00

(*, 224.0.1.40), 00:10:05/00:02:55, RP 10.3.3.3, flags: SJCL
  Incoming interface: GigabitEthernet0/1, RPF nbr 10.0.23.3
  Outgoing interface list:
    GigabitEthernet0/0, Forward/Sparse, 00:10:04/00:02:55

IOSv3

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
IOSv3# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:08:57/00:03:21, RP 10.3.3.3, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet0/2, Forward/Sparse, 00:08:57/00:03:21

(10.0.12.1, 224.1.1.1), 00:00:31/00:02:32, flags: T
  Incoming interface: GigabitEthernet0/1, RPF nbr 10.0.23.2
  Outgoing interface list:
    GigabitEthernet0/2, Forward/Sparse, 00:00:31/00:03:21

(*, 224.0.1.40), 00:09:52/00:03:18, RP 10.3.3.3, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet0/2, Forward/Sparse, 00:08:57/00:03:18
    GigabitEthernet0/1, Forward/Sparse, 00:09:01/00:03:13
    Loopback0, Forward/Sparse, 00:09:51/00:02:09

IOSv4

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
IOSv4# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:10:00/00:02:09, RP 10.3.3.3, flags: SC
  Incoming interface: GigabitEthernet0/2, RPF nbr 10.0.34.3
  Outgoing interface list:
    GigabitEthernet0/4, Forward/Sparse, 00:09:59/00:02:09

(*, 224.0.1.40), 00:10:00/00:02:13, RP 10.3.3.3, flags: SPCL
  Incoming interface: GigabitEthernet0/2, RPF nbr 10.0.34.3
  Outgoing interface list: Null

IOSv5

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
IOSv5# show ip mroute
IP Multicast Forwarding is not enabled.
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

障害時動作

IOSv2 ~ IOSv3 (RP) 間を閉塞し、障害時動作を確認します。

インターフェイス閉塞

IOSv2

1
2
3
4
IOSv2# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
IOSv2(config)# interface GigabitEthernet 0/1
IOSv2(config-if)# shutdown

通信確認

IOSv1

1
2
3
4
5
6
7
8
9
IOSv1# ping 224.1.1.1 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:

Reply to request 0 from 10.0.45.5, 61 ms
Reply to request 1 from 10.0.45.5, 29 ms
Reply to request 2 from 10.0.45.5, 14 ms
Reply to request 3 from 10.0.45.5, 9 ms
Reply to request 4 from 10.0.45.5, 9 ms

show ip mroute

file

IOSv1

1
2
IOSv1# show ip mroute 224.1.1.1
Group 224.1.1.1 not found

IOSv2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
IOSv2# show ip mroute 224.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:00:39/stopped, RP 10.3.3.3, flags: SPF
  Incoming interface: GigabitEthernet0/3, RPF nbr 10.0.24.4
  Outgoing interface list: Null

(10.0.12.1, 224.1.1.1), 00:00:39/00:02:54, flags: FT
  Incoming interface: GigabitEthernet0/0, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet0/3, Forward/Sparse, 00:00:38/00:02:51

IOSv3

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
IOSv3# show ip mroute 224.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:48:21/stopped, RP 10.3.3.3, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet0/2, Forward/Sparse, 00:48:21/00:02:46

(10.0.12.1, 224.1.1.1), 00:00:38/00:02:24, flags: PT
  Incoming interface: GigabitEthernet0/2, RPF nbr 10.0.34.4
  Outgoing interface list: Null

IOSv4

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
IOSv4# show ip mroute 224.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
       Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
       V - RD & Vector, v - Vector, p - PIM Joins on route, 
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:50:05/stopped, RP 10.3.3.3, flags: SC
  Incoming interface: GigabitEthernet0/2, RPF nbr 10.0.34.3
  Outgoing interface list:
    GigabitEthernet0/4, Forward/Sparse, 00:50:04/00:02:59

(10.0.12.1, 224.1.1.1), 00:00:40/00:02:19, flags: T
  Incoming interface: GigabitEthernet0/3, RPF nbr 10.0.24.2
  Outgoing interface list:
    GigabitEthernet0/4, Forward/Sparse, 00:00:40/00:02:59

IOSv5

1
2
IOSv5# show ip mroute 224.1.1.1
Group 224.1.1.1 not found