Skip to content

CML2 のラボをエクスポート / インポートする

以前に CML で起動前にコンフィグを設定しておく というメモに記載した通り、CML2 ではノードの起動前に予めコンフィグを設定しておくことが出来ます。 この事前に設定されたコンフィグを含め、ラボ全体のトポロジーをエクスポート / インポートすることが出来ます。 今回はその手順をメモしておきます。

前提となるラボ

今回は以下のトポロジーを作成しました。

file

IOSv1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
hostname IOSv-1
!
interface GigabitEthernet0/0
 ip vrf forwarding management
 ip address dhcp
 no shutdown
!
interface GigabitEthernet0/1
 ip address 10.0.0.1 255.255.255.0
 no shutdown
!
end

IOSv2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
hostname IOSv-2
!
interface GigabitEthernet0/0
 ip vrf forwarding management
 ip address dhcp
 no shutdown
!
interface GigabitEthernet0/1
 ip address 10.0.0.2 255.255.255.0
 no shutdown
!
end

エクスポート手順

ラボの構成をエクスポートするには、ラボを選択した状態で SIMULATEDOWNLOAD LAB を選択します。 これでラボの構成が .yaml ファイルとして保存されます。 このファイルには EDIT CONFIG に事前設定したコンフィグも含まれます。

file

かなり長いですが、実際にエクスポートした .yaml ファイルは以下です。

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
lab:
  description: ''
  notes: ''
  timestamp: 1634779391.2947512
  title: Lab-1
  version: 0.0.4
nodes:
  - id: n0
    label: unmanaged-switch-0
    node_definition: unmanaged_switch
    x: -250
    y: -100
    configuration: ''
    tags: []
    interfaces:
      - id: i0
        slot: 0
        label: port0
        type: physical
      - id: i1
        slot: 1
        label: port1
        type: physical
      - id: i2
        slot: 2
        label: port2
        type: physical
      - id: i3
        slot: 3
        label: port3
        type: physical
      - id: i4
        slot: 4
        label: port4
        type: physical
      - id: i5
        slot: 5
        label: port5
        type: physical
      - id: i6
        slot: 6
        label: port6
        type: physical
      - id: i7
        slot: 7
        label: port7
        type: physical
  - id: n1
    label: ext-conn-0
    node_definition: external_connector
    x: -250
    y: -200
    configuration: bridge0
    tags: []
    interfaces:
      - id: i0
        slot: 0
        label: port
        type: physical
  - id: n2
    label: IOSv-1
    node_definition: iosv
    x: -400
    y: 0
    configuration: |-
      hostname IOSv-1
      !
      interface GigabitEthernet0/0
       ip vrf forwarding management
       ip address dhcp
       no shutdown
      !
      interface GigabitEthernet0/1
       ip address 10.0.0.1 255.255.255.0
       no shutdown
      !
      end
    image_definition: iosv-159-3-m3
    tags: []
    interfaces:
      - id: i0
        label: Loopback0
        type: loopback
      - id: i1
        slot: 0
        label: GigabitEthernet0/0
        type: physical
      - id: i2
        slot: 1
        label: GigabitEthernet0/1
        type: physical
      - id: i3
        slot: 2
        label: GigabitEthernet0/2
        type: physical
      - id: i4
        slot: 3
        label: GigabitEthernet0/3
        type: physical
  - id: n3
    label: IOSv-2
    node_definition: iosv
    x: -100
    y: 0
    configuration: |-
      hostname IOSv-2
      !
      interface GigabitEthernet0/0
       ip vrf forwarding management
       ip address dhcp
       no shutdown
      !
      interface GigabitEthernet0/1
       ip address 10.0.0.2 255.255.255.0
       no shutdown
      !
      end
    image_definition: iosv-159-3-m3
    tags: []
    interfaces:
      - id: i0
        label: Loopback0
        type: loopback
      - id: i1
        slot: 0
        label: GigabitEthernet0/0
        type: physical
      - id: i2
        slot: 1
        label: GigabitEthernet0/1
        type: physical
      - id: i3
        slot: 2
        label: GigabitEthernet0/2
        type: physical
      - id: i4
        slot: 3
        label: GigabitEthernet0/3
        type: physical
links:
  - id: l0
    i1: i0
    n1: n1
    i2: i0
    n2: n0
  - id: l1
    i1: i1
    n1: n0
    i2: i1
    n2: n2
  - id: l2
    i1: i2
    n1: n0
    i2: i1
    n2: n3
  - id: l3
    i1: i2
    n1: n2
    i2: i2
    n2: n3

インポート手順

エクスポートした .yaml ファイルをインポートするにはダッシュボード (CML2 のトップ画面) 右上にある IMPORT をクリックします。

file

ラボの構成ファイルを選択するよう促されるのでエクスポートした .yaml ファイルをアップロードします。

file

アップロードが完了したら IMPORT をクリックします。

file

インポートが完了しました。 GO TO LAB をクリックします。

file

インポートされたラボが表示されます。

file