Skip to content

CML 上の Catalyst 8000V でライセンスを有効化/スループットレベルを変更する

Cisco CML 上で Catalyst 8000V を起動しても、ライセンスが存在しない為、ライセンスを必要とする機能を利用することが出来ません。 評価用途であれば申請など無く、一時的にライセンスを有効化することが出来る為、今回はその手順をメモしておきます。 尚、ライセンス毎の機能差 / 特徴は Cisco DNA ライセンスの比較 に書かれています。

デフォルトの状態

CML 上で Catalyst 8000V を起動するとデフォルトでは以下のようにライセンスが存在しません。

1
2
3
4
5
inserthostname_here# show license summary
License Usage:
  License                 Entitlement Tag               Count Status
  -----------------------------------------------------------------------------
  No licenses in use

スループットレベルはデフォルトで 10Mbps (10,000Kbps) になっています。

1
2
inserthostname_here# show platform hardware throughput level
The current throughput level is 10000 kb/s
1
2
inserthostname_here# show version | include throughput
The current throughput level is 10000 kbps

ライセンスの有効化

ライセンスを有効化するには以下を実行します。 ライセンスを有効化するにはコマンド実行後に再起動する必要があります。 尚、後述するスループットレベルの変更を行う為には予めライセンスが変更されている必要があるようで、「ライセンスの有効化」と「スループットレベルの変更」を同時に実施することは出来ないようです。

1
2
3
4
5
6
configure terminal
license boot level network-premier addon dna-premier
end

write memory 
reload

実際の実行例は以下です。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
inserthostname_here# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
inserthostname_here(config)# license boot level network-premier addon dna-premier
% use 'write' command to make license boot config take effect on next boot

inserthostname_here(config)# end
inserthostname_here#
inserthostname_here# write memory
Building configuration...
[OK]
inserthostname_here#
inserthostname_here# reload
Proceed with reload? [confirm]

*Apr 24 05:11:11.010: %SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload Command.

これでライセンスが有効化されました。 show version で確認すると License Level: network-premier になっていることが分かります。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
inserthostname_here# show version
(snip)
License Level: network-premier
License Type: Perpetual
Next reload license Level: network-premier

Addon License Level: dna-premier
Addon License Type: Subscription
Next reload addon license Level: dna-premier

The current throughput level is 10000 kbps

ただ、原因がわかりませんが、この状態で show license summary を実行してもなぜかライセンスが表示されません… (ですが、実際にはライセンス相応の機能を利用出来ますので、実害はありません)。

1
2
3
4
5
inserthostname_here# show license summary
License Usage:
  License                 Entitlement Tag               Count Status
  -----------------------------------------------------------------------------
  No licenses in use

スループットレベルの変更

スループットレベルを変更するには以下を実行します。

1
2
3
4
5
6
configure terminal
platform hardware throughput level MB 250
!
end

write memory 

実際の実行例は以下です。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
inserthostname_here# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
inserthostname_here(config)# platform hardware throughput level ?
  MB  throughput in mbps

inserthostname_here(config)# platform hardware throughput level MB ?
  100    Mbps
  1000   Mbps
  10000  Mbps
  15     Mbps
  25     Mbps
  250    Mbps
  2500   Mbps
  50     Mbps
  500    Mbps
  5000   Mbps

inserthostname_here(config)# platform hardware throughput level MB 10000
%Requested throughput will be set once HSEC authorization code is installed
%Throughput has been set to 250 Mbps

inserthostname_here(config)#

show platform hardware throughput level で確認すると 250Mbps (250,000Kbps) へ変更されていることが分かります。

1
2
inserthostname_here# show platform hardware throughput level
The current throughput level is 250000 kb/s

ライセンス状態の再確認

前述の通り、「ライセンス有効化直後に show license summary を実行してもライセンスが表示されない」のですが、スループットレベル変更後であれば以下のようにライセンスが表示されます。

1
2
3
4
5
6
inserthostname_here# show license summary
License Usage:
  License                 Entitlement Tag               Count Status
  -----------------------------------------------------------------------------
  network-premier_250M    (ESR_P_250M_P)                    1 IN USE
  dna-premier_250M        (DNA_P_250M_P)                    1 IN USE

スループットレベルは変更直後から値が表示されます。

1
2
inserthostname_here# show platform hardware throughput level
The current throughput level is 250000 kb/s
1
2
inserthostname_here# show version | include throughput
The current throughput level is 250000 kbps

参考

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
inserthostname_here# show running-config
Building configuration...

Current configuration : 3632 bytes
!
! Last configuration change at 05:04:00 UTC Sun Apr 24 2022
!
version 17.6
service timestamps debug datetime msec
service timestamps log datetime msec
! Call-home is enabled by Smart-Licensing.
service call-home
platform qfp utilization monitor load 80
platform punt-keepalive disable-kernel-core
platform console serial
!
hostname inserthostname_here
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
login on-success log
!
!
!
!
!
!
!
subscriber templating
!
multilink bundle-name authenticated
!
!
!
crypto pki trustpoint SLA-TrustPoint
 enrollment pkcs12
 revocation-check crl
!
!
crypto pki certificate chain SLA-TrustPoint
 certificate ca 01
  30820321 30820209 A0030201 02020101 300D0609 2A864886 F70D0101 0B050030
  32310E30 0C060355 040A1305 43697363 6F312030 1E060355 04031317 43697363
  6F204C69 63656E73 696E6720 526F6F74 20434130 1E170D31 33303533 30313934
  3834375A 170D3338 30353330 31393438 34375A30 32310E30 0C060355 040A1305
  43697363 6F312030 1E060355 04031317 43697363 6F204C69 63656E73 696E6720
  526F6F74 20434130 82012230 0D06092A 864886F7 0D010101 05000382 010F0030
  82010A02 82010100 A6BCBD96 131E05F7 145EA72C 2CD686E6 17222EA1 F1EFF64D
  CBB4C798 212AA147 C655D8D7 9471380D 8711441E 1AAF071A 9CAE6388 8A38E520
  1C394D78 462EF239 C659F715 B98C0A59 5BBB5CBD 0CFEBEA3 700A8BF7 D8F256EE
  4AA4E80D DB6FD1C9 60B1FD18 FFC69C96 6FA68957 A2617DE7 104FDC5F EA2956AC
  7390A3EB 2B5436AD C847A2C5 DAB553EB 69A9A535 58E9F3E3 C0BD23CF 58BD7188
  68E69491 20F320E7 948E71D7 AE3BCC84 F10684C7 4BC8E00F 539BA42B 42C68BB7
  C7479096 B4CB2D62 EA2F505D C7B062A4 6811D95B E8250FC4 5D5D5FB8 8F27D191
  C55F0D76 61F9A4CD 3D992327 A8BB03BD 4E6D7069 7CBADF8B DF5F4368 95135E44
  DFC7C6CF 04DD7FD1 02030100 01A34230 40300E06 03551D0F 0101FF04 04030201
  06300F06 03551D13 0101FF04 05300301 01FF301D 0603551D 0E041604 1449DC85
  4B3D31E5 1B3E6A17 606AF333 3D3B4C73 E8300D06 092A8648 86F70D01 010B0500
  03820101 00507F24 D3932A66 86025D9F E838AE5C 6D4DF6B0 49631C78 240DA905
  604EDCDE FF4FED2B 77FC460E CD636FDB DD44681E 3A5673AB 9093D3B1 6C9E3D8B
  D98987BF E40CBD9E 1AECA0C2 2189BB5C 8FA85686 CD98B646 5575B146 8DFC66A8
  467A3DF4 4D565700 6ADF0F0D CF835015 3C04FF7C 21E878AC 11BA9CD2 55A9232C
  7CA7B7E6 C1AF74F6 152E99B7 B1FCF9BB E973DE7F 5BDDEB86 C71E3B49 1765308B
  5FB0DA06 B92AFE7F 494E8A9E 07B85737 F3A58BE1 1A48A229 C37C1E69 39F08678
  80DDCD16 D6BACECA EEBC7CF9 8428787B 35202CDC 60E4616A B623CDBD 230E3AFB
  418616A9 4093E049 4D10AB75 27E86F73 932E35B5 8862FDAE 0275156F 719BB2F0
  D697DF7F 28
   quit
!
license udi pid C8000V sn 98AOLD8A0X2
diagnostic bootup level minimal
memory free low-watermark processor 68484
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
interface GigabitEthernet1
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet2
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet3
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet4
 no ip address
 shutdown
 negotiation auto
!
ip forward-protocol nd
no ip http server
ip http secure-server
!
!
!
!
!
!
control-plane
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 1
 login
 transport input ssh
line vty 2
 login
 length 0
 transport input ssh
line vty 3 4
 login
 transport input ssh
!
call-home
 ! If contact email address in call-home is configured as sch-smart-licensing@cisco.com
 ! the email address configured in Cisco Smart License Portal will be used as contact email address to send SCH notifications.
 contact-email-addr sch-smart-licensing@cisco.com
 profile "CiscoTAC-1"
  active
  destination transport-method http
!
!
!
!
!
!
end