Skip to content

Catalyst 8000V で MPLS を設定する

Catalyst 8000V (IOS-XE 17.10.01a) でも MPLS 設定例をメモしておきます。

ライセンスの有効化

以前に CML 上の Catalyst 8000V でライセンスを有効化/スループットレベルを変更する というメモを書きましたが、MPLS 網内を構成する PE / P ルータでは MPLS を利用する為、ライセンスを有効化しておきます。 具体的には以下を実行します。

1
2
3
4
5
6
configure terminal
license boot level network-premier addon dna-premier
end

write memory 
reload

構成図

file

コンフィグ

dev1

1
2
3
4
5
6
7
8
9
hostname dev1
!
interface GigabitEthernet3
 ip address 172.16.12.1 255.255.255.0
 no shutdown
!
ip route 0.0.0.0 0.0.0.0 172.16.12.2
!
end

dev2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
hostname dev2
!
ip vrf 100
 rd 1:100
 route-target export 1:100
 route-target import 1:100
!
interface Loopback0
 ip address 10.0.99.2 255.255.255.255
!
interface GigabitEthernet2
 ip vrf forwarding 100
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!
interface GigabitEthernet3
 ip address 10.0.23.2 255.255.255.0
 mpls ip
 no shutdown
!
router ospf 65000
 router-id 10.0.99.2
 network 10.0.0.0 0.0.255.255 area 0.0.0.0
!
router bgp 65000
 bgp router-id 10.0.99.2
 bgp log-neighbor-changes
 neighbor 10.0.99.9 remote-as 65000
 neighbor 10.0.99.9 update-source Loopback0
 !
 address-family vpnv4
  neighbor 10.0.99.9 activate
  neighbor 10.0.99.9 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf 100
  redistribute connected
 exit-address-family
!
end

dev3

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
hostname dev3
!
interface Loopback0
 ip address 10.0.99.3 255.255.255.255
!
interface GigabitEthernet2
 ip address 10.0.23.3 255.255.255.0
 mpls ip
 no shutdown
!
interface GigabitEthernet3
 ip address 10.0.34.3 255.255.255.0
 mpls ip
 no shutdown
!
interface GigabitEthernet4
 ip address 10.0.39.3 255.255.255.0
 mpls ip
 no shutdown
!
router ospf 65000
 router-id 10.0.99.3
 network 10.0.0.0 0.0.255.255 area 0.0.0.0
!
end

dev4

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
hostname dev4
!
ip vrf 100
 rd 1:100
 route-target export 1:100
 route-target import 1:100
!
interface Loopback0
 ip address 10.0.99.4 255.255.255.255
!
interface GigabitEthernet2
 ip address 10.0.34.4 255.255.255.0
 mpls ip
 no shutdown
!
interface GigabitEthernet3
 ip vrf forwarding 100
 ip address 172.16.45.4 255.255.255.0
 no shutdown
!
router ospf 65000
 router-id 10.0.99.4
 network 10.0.0.0 0.0.255.255 area 0.0.0.0
!
router bgp 65000
 bgp router-id 10.0.99.4
 bgp log-neighbor-changes
 neighbor 10.0.99.9 remote-as 65000
 neighbor 10.0.99.9 update-source Loopback0
 !
 address-family vpnv4
  neighbor 10.0.99.9 activate
  neighbor 10.0.99.9 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf 100
  redistribute connected
 exit-address-family
!
end

dev5

1
2
3
4
5
6
7
8
9
hostname dev5
!
interface GigabitEthernet2
 ip address 172.16.45.5 255.255.255.0
 no shutdown
!
ip route 0.0.0.0 0.0.0.0 172.16.45.4
!
end

dev9

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
hostname dev9
!
interface Loopback0
 ip address 10.0.99.9 255.255.255.255
!
interface GigabitEthernet2
 ip address 10.0.39.9 255.255.255.0
 mpls ip
 no shutdown
!
router ospf 65000
 router-id 10.0.99.9
 network 10.0.0.0 0.0.255.255 area 0.0.0.0
!
router bgp 65000
 bgp router-id 10.0.99.9
 bgp log-neighbor-changes
 neighbor 10.0.99.2 remote-as 65000
 neighbor 10.0.99.2 update-source Loopback0
 neighbor 10.0.99.2 route-reflector-client
 neighbor 10.0.99.4 remote-as 65000
 neighbor 10.0.99.4 update-source Loopback0
 neighbor 10.0.99.4 route-reflector-client
 !
 address-family vpnv4
  neighbor 10.0.99.2 activate
  neighbor 10.0.99.2 send-community extended
  neighbor 10.0.99.2 route-reflector-client
  neighbor 10.0.99.4 activate
  neighbor 10.0.99.4 send-community extended
  neighbor 10.0.99.4 route-reflector-client
 exit-address-family
!
end