Skip to content

バック・ツー・バック / マルチキャストの BGP EVPN VXALN 設定例

「Cisco IOS XE Bengaluru 17.6.x(Catalyst 9300 スイッチ)BGP EVPN VXLAN コンフィギュレーション ガイド」の 例:バック ツー バック マルチキャスト複製を使用したレイヤ 2 VNI の設定 を参考に EVPN VXLAN を設定してみたのでメモしておきます。 スパインを用いないバック・ツー・バック接続、マルチキャスト構成を利用しています。

構成図

CML 上で以下の構成を作成しました。

file

host / vtep は以下を利用しています。

役割 機種 バージョン
host Catalyst 8000v 17.10.01a
vtep Catalyst 9000v 17.10.01prd7

コンフィグ

host1

1
2
3
4
5
6
7
8
hostname host1
!
interface GigabitEthernet2
 mac-address 0000.1111.1111
 ip address 192.168.10.11 255.255.255.0
 no shutdown
!
end

host2

1
2
3
4
5
6
7
8
hostname host2
!
interface GigabitEthernet2
 mac-address 0000.2222.2222
 ip address 192.168.10.22 255.255.255.0
 no shutdown
!
end

vtep1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
hostname vtep1
!
ip routing
!
ip multicast-routing
!
l2vpn evpn
 replication-type static
 router-id Loopback0
!
l2vpn evpn instance 10 vlan-based
 encapsulation vxlan
!
system mtu 8978
!
vlan configuration 10
 member evpn-instance 10 vni 10010
!
interface Loopback0
 ip address 10.0.99.1 255.255.255.255
 ip pim sparse-mode
 ip ospf 65000 area 0.0.0.0
!
interface GigabitEthernet1/0/1
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 no shutdown
!
interface GigabitEthernet1/0/2
 no switchport
 ip address 10.0.0.1 255.255.255.252
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 65000 area 0.0.0.0
 no shutdown
!
interface nve1
 no ip address
 source-interface Loopback0
 host-reachability protocol bgp
 member vni 10010 mcast-group 225.0.0.10
!
router ospf 65000
 router-id 10.0.99.1
!
router bgp 65000
 neighbor 10.0.99.2 remote-as 65000
 neighbor 10.0.99.2 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family l2vpn evpn
  neighbor 10.0.99.2 activate
  neighbor 10.0.99.2 send-community both
 exit-address-family
!
ip pim rp-address 10.0.99.1
!
end

vtep2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
hostname vtep2
!
ip routing
!
ip multicast-routing
!
l2vpn evpn
 replication-type static
 router-id Loopback0
!
l2vpn evpn instance 10 vlan-based
 encapsulation vxlan
!
system mtu 8978
!
vlan configuration 10
 member evpn-instance 10 vni 10010
!
interface Loopback0
 ip address 10.0.99.2 255.255.255.255
 ip pim sparse-mode
 ip ospf 65000 area 0.0.0.0
!
interface GigabitEthernet1/0/1
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 no shutdown
!
interface GigabitEthernet1/0/2
 no switchport
 ip address 10.0.0.2 255.255.255.252
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 65000 area 0.0.0.0
 no shutdown
!
interface nve1
 no ip address
 source-interface Loopback0
 host-reachability protocol bgp
 member vni 10010 mcast-group 225.0.0.10
!
router ospf 65000
 router-id 10.0.99.2
!
router bgp 65000
 neighbor 10.0.99.1 remote-as 65000
 neighbor 10.0.99.1 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family l2vpn evpn
  neighbor 10.0.99.1 activate
  neighbor 10.0.99.1 send-community both
 exit-address-family
!
ip pim rp-address 10.0.99.1
!
end

確認コマンド

設定後は以下のコマンドで状態確認しています。

  • show nve peers
  • show bgp l2vpn evpn summary
  • show bgp l2vpn evpn
  • show l2vpn evpn mac evi 10
  • show ip mroute
  • show ip mfib

End to End での通信確認前

show nve peers

vtep1

1
2
3
4
5
vtep1# show nve peers
'M' - MAC entry download flag  'A' - Adjacency download flag
'4' - IPv4 flag  '6' - IPv6 flag

Interface  VNI      Type Peer-IP          RMAC/Num_RTs   eVNI     state flags UP time

vtep2

1
2
3
4
5
vtep2# show nve peers
'M' - MAC entry download flag  'A' - Adjacency download flag
'4' - IPv4 flag  '6' - IPv6 flag

Interface  VNI      Type Peer-IP          RMAC/Num_RTs   eVNI     state flags UP time

show bgp l2vpn evpn summary

vtep1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
vtep1# show bgp l2vpn evpn summary
BGP router identifier 10.0.99.1, local AS number 65000
BGP table version is 1, main routing table version 1
1 network entries using 384 bytes of memory
1 path entries using 232 bytes of memory
1/0 BGP path/bestpath attribute entries using 296 bytes of memory
1 BGP extended community entries using 40 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 952 total bytes of memory
BGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs
1 networks peaked at 23:31:30 Mar 11 2023 JST (00:00:36.706 ago)

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.99.2       4        65000       2       2        1    0    0 00:00:12        0

vtep2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
vtep2# show bgp l2vpn evpn summary
BGP router identifier 10.0.99.2, local AS number 65000
BGP table version is 1, main routing table version 1
2 network entries using 768 bytes of memory
2 path entries using 464 bytes of memory
1/0 BGP path/bestpath attribute entries using 296 bytes of memory
1 BGP extended community entries using 40 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1568 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs
2 networks peaked at 23:31:53 Mar 11 2023 JST (00:00:16.003 ago)

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.99.1       4        65000       2       2        1    0    0 00:00:15        0

show bgp l2vpn evpn

vtep1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
vtep1# show bgp l2vpn evpn
BGP table version is 6, local router ID is 10.0.99.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
              t secondary path, L long-lived-stale,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10.0.99.1:10
 *>i  [2][10.0.99.1:10][0][48][5254000DED83][0][*]/20
                      10.0.99.2                0    100      0 ?
 *>i  [2][10.0.99.1:10][0][48][5254000DED83][128][FE80::5054:FF:FE0D:ED83]/36
                      10.0.99.2                0    100      0 ?
 *>   [2][10.0.99.1:10][0][48][5254001CC43A][128][FE80::5054:FF:FE1C:C43A]/36
                      0.0.0.0                            32768 ?
Route Distinguisher: 10.0.99.2:10
 *>i  [2][10.0.99.2:10][0][48][5254000DED83][0][*]/20
                      10.0.99.2                0    100      0 ?
 *>i  [2][10.0.99.2:10][0][48][5254000DED83][128][FE80::5054:FF:FE0D:ED83]/36
                      10.0.99.2                0    100      0 ?

vtep2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
vtep2# show bgp l2vpn evpn
BGP table version is 5, local router ID is 10.0.99.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
              t secondary path, L long-lived-stale,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10.0.99.1:10
 *>i  [2][10.0.99.1:10][0][48][5254001CC43A][128][FE80::5054:FF:FE1C:C43A]/36
                      10.0.99.1                0    100      0 ?
Route Distinguisher: 10.0.99.2:10
 *>   [2][10.0.99.2:10][0][48][5254000DED83][0][*]/20
                      0.0.0.0                            32768 ?
 *>   [2][10.0.99.2:10][0][48][5254000DED83][128][FE80::5054:FF:FE0D:ED83]/36
                      0.0.0.0                            32768 ?
 *>i  [2][10.0.99.2:10][0][48][5254001CC43A][128][FE80::5054:FF:FE1C:C43A]/36
                      10.0.99.1                0    100      0 ?

show l2vpn evpn mac evi 10

vtep1

1
2
3
4
vtep1# show l2vpn evpn mac evi 10
MAC Address    EVI   VLAN  ESI                      Ether Tag  Next Hop(s)
-------------- ----- ----- ------------------------ ---------- ---------------
5254.001c.c43a 10    10    0000.0000.0000.0000.0000 0          Gi1/0/1:10

vtep2

1
2
3
4
vtep2# show l2vpn evpn mac evi 10
MAC Address    EVI   VLAN  ESI                      Ether Tag  Next Hop(s)
-------------- ----- ----- ------------------------ ---------- ---------------
5254.001c.c43a 10    10    0000.0000.0000.0000.0000 0          10.0.99.1

show ip mroute

vtep1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
vtep1# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag, l - LISP decap ref count contributor
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
                          t - LISP transit group
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 225.0.0.10), 00:13:50/00:03:08, RP 10.0.99.1, flags: SJCx
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet1/0/2, Forward/Sparse, 00:08:12/00:03:08, flags:
    Tunnel0, Forward/Sparse-Dense, 00:13:50/stopped, flags:

(*, 224.0.1.40), 00:13:59/00:03:09, RP 10.0.99.1, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet1/0/2, Forward/Sparse, 00:08:11/00:03:09, flags:
    Loopback0, Forward/Sparse, 00:13:57/00:02:00, flags:

vtep2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
vtep2# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag, l - LISP decap ref count contributor
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
                          t - LISP transit group
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 225.0.0.10), 00:08:20/stopped, RP 10.0.99.1, flags: SJCx
  Incoming interface: GigabitEthernet1/0/2, RPF nbr 10.0.0.1
  Outgoing interface list:
    Tunnel0, Forward/Sparse-Dense, 00:08:20/stopped, flags:

(*, 224.0.1.40), 00:08:20/00:02:42, RP 10.0.99.1, flags: SJCL
  Incoming interface: GigabitEthernet1/0/2, RPF nbr 10.0.0.1
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:08:18/00:02:42, flags:

show ip mfib

vtep1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
vtep1# show ip mfib
Entry Flags:    C - Directly Connected, S - Signal, IA - Inherit A flag,
                ET - Data Rate Exceeds Threshold, K - Keepalive
                DDE - Data Driven Event, HW - Hardware Installed
                ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
                MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
                MS  - MoFRR  Entry in Sync, MC - MoFRR entry in MoFRR Client,
                e   - Encap helper tunnel flag.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
                NS - Negate Signalling, SP - Signal Present,
                A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
                MA - MFIB Accept, A2 - Accept backup,
                RA2 - MRIB Accept backup, MA2 - MFIB Accept backup

Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts:      Total/RPF failed/Other drops
I/O Item Counts:   HW Pkt Count/FS Pkt Count/PS Pkt Count   Egress Rate in pps
Default
 (*,224.0.0.0/4) Flags: C HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   0/0/0/0, Other: 0/0/0
 (*,224.0.1.40) Flags: C HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   0/0/0/0, Other: 0/0/0
   Tunnel2 Flags: A NP
   GigabitEthernet1/0/2 Flags: F NS
     Pkts: 0/0/0    Rate: 0 pps
   Loopback0 Flags: F IC NS
     Pkts: 0/0/0    Rate: 0 pps
 (*,225.0.0.10) Flags: C HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   1/0/124/0, Other: 0/0/0
   Tunnel2 Flags: A NP
   GigabitEthernet1/0/2 Flags: F NS
     Pkts: 0/0/0    Rate: 0 pps
   Tunnel0, VXLAN Decap Flags: F NS
     Pkts: 0/0/0    Rate: 0 pps

vtep2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
vtep2# show ip mfib
Entry Flags:    C - Directly Connected, S - Signal, IA - Inherit A flag,
                ET - Data Rate Exceeds Threshold, K - Keepalive
                DDE - Data Driven Event, HW - Hardware Installed
                ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
                MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
                MS  - MoFRR  Entry in Sync, MC - MoFRR entry in MoFRR Client,
                e   - Encap helper tunnel flag.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
                NS - Negate Signalling, SP - Signal Present,
                A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
                MA - MFIB Accept, A2 - Accept backup,
                RA2 - MRIB Accept backup, MA2 - MFIB Accept backup

Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts:      Total/RPF failed/Other drops
I/O Item Counts:   HW Pkt Count/FS Pkt Count/PS Pkt Count   Egress Rate in pps
Default
 (*,224.0.0.0/4) Flags: C HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   0/0/0/0, Other: 0/0/0
 (*,224.0.1.40) Flags: C HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   0/0/0/0, Other: 0/0/0
   GigabitEthernet1/0/2 Flags: A NS
   Loopback0 Flags: F IC NS
     Pkts: 0/0/0    Rate: 0 pps
 (*,225.0.0.10) Flags: C HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   1/0/124/0, Other: 0/0/0
   GigabitEthernet1/0/2 Flags: A NS
   Tunnel0, VXLAN Decap Flags: F NS
     Pkts: 0/0/0    Rate: 0 pps

End to End での通信確認

show ip arp & ping

vtep1

1
2
3
host1# show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.10.11           -   0000.1111.1111  ARPA   GigabitEthernet2
1
2
3
4
5
host1# ping 192.168.10.22
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.22, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 51/56/66 ms
1
2
3
4
host1# show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.10.11           -   0000.1111.1111  ARPA   GigabitEthernet2
Internet  192.168.10.22           0   0000.2222.2222  ARPA   GigabitEthernet2

End to End での通信確認後

show nve peers

vtep1

1
2
3
4
5
6
vtep1# show nve peers
'M' - MAC entry download flag  'A' - Adjacency download flag
'4' - IPv4 flag  '6' - IPv6 flag

Interface  VNI      Type Peer-IP          RMAC/Num_RTs   eVNI     state flags UP time
nve1       10010    L2CP 10.0.99.2        2              10010      UP   N/A  00:00:14

vtep2

1
2
3
4
5
6
vtep2# show nve peers
'M' - MAC entry download flag  'A' - Adjacency download flag
'4' - IPv4 flag  '6' - IPv6 flag

Interface  VNI      Type Peer-IP          RMAC/Num_RTs   eVNI     state flags UP time
nve1       10010    L2CP 10.0.99.1        4              10010      UP   N/A  00:10:03

show bgp l2vpn evpn summary

vtep1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
vtep1# show bgp l2vpn evpn summary
BGP router identifier 10.0.99.1, local AS number 65000
BGP table version is 22, main routing table version 22
5 network entries using 1920 bytes of memory
5 path entries using 1160 bytes of memory
2/2 BGP path/bestpath attribute entries using 592 bytes of memory
1 BGP extended community entries using 40 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 3712 total bytes of memory
BGP activity 11/6 prefixes, 13/8 paths, scan interval 60 secs
7 networks peaked at 23:38:22 Mar 11 2023 JST (00:04:42.087 ago)

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.99.2       4        65000      20      18       22    0    0 00:11:10        1

vtep2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
vtep2# show bgp l2vpn evpn summary
BGP router identifier 10.0.99.2, local AS number 65000
BGP table version is 16, main routing table version 16
7 network entries using 2688 bytes of memory
7 path entries using 1624 bytes of memory
2/2 BGP path/bestpath attribute entries using 592 bytes of memory
1 BGP extended community entries using 40 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 4944 total bytes of memory
BGP activity 10/3 prefixes, 11/4 paths, scan interval 60 secs
8 networks peaked at 23:38:22 Mar 11 2023 JST (00:04:44.592 ago)

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.99.1       4        65000      18      20       16    0    0 00:11:12        3

show bgp l2vpn evpn

vtep1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
vtep1# show bgp l2vpn evpn
BGP table version is 25, local router ID is 10.0.99.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
              t secondary path, L long-lived-stale,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10.0.99.1:10
 *>   [2][10.0.99.1:10][0][48][000011111111][32][192.168.10.11]/24
                      0.0.0.0                            32768 ?
 *>i  [2][10.0.99.1:10][0][48][000022222222][32][192.168.10.22]/24
                      10.0.99.2                0    100      0 ?
 *>   [2][10.0.99.1:10][0][48][5254001CC43A][128][FE80::5054:FF:FE1C:C43A]/36
                      0.0.0.0                            32768 ?
Route Distinguisher: 10.0.99.2:10
 *>i  [2][10.0.99.2:10][0][48][000022222222][32][192.168.10.22]/24
                      10.0.99.2                0    100      0 ?

vtep2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
vtep2# show bgp l2vpn evpn
BGP table version is 22, local router ID is 10.0.99.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
              t secondary path, L long-lived-stale,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10.0.99.1:10
 *>i  [2][10.0.99.1:10][0][48][000011111111][32][192.168.10.11]/24
                      10.0.99.1                0    100      0 ?
 *>i  [2][10.0.99.1:10][0][48][5254001CC43A][128][FE80::5054:FF:FE1C:C43A]/36
                      10.0.99.1                0    100      0 ?
Route Distinguisher: 10.0.99.2:10
 *>i  [2][10.0.99.2:10][0][48][000011111111][32][192.168.10.11]/24
                      10.0.99.1                0    100      0 ?
 *>   [2][10.0.99.2:10][0][48][000022222222][32][192.168.10.22]/24
                      0.0.0.0                            32768 ?
 *>i  [2][10.0.99.2:10][0][48][5254001CC43A][128][FE80::5054:FF:FE1C:C43A]/36
                      10.0.99.1                0    100      0 ?

show l2vpn evpn mac evi 10

vtep1

1
2
3
4
5
6
vtep1# show l2vpn evpn mac evi 10
MAC Address    EVI   VLAN  ESI                      Ether Tag  Next Hop(s)
-------------- ----- ----- ------------------------ ---------- ---------------
0000.1111.1111 10    10    0000.0000.0000.0000.0000 0          Gi1/0/1:10
0000.2222.2222 10    10    0000.0000.0000.0000.0000 0          10.0.99.2
5254.001c.c43a 10    10    0000.0000.0000.0000.0000 0          Gi1/0/1:10

vtep2

1
2
3
4
5
6
vtep2# show l2vpn evpn mac evi 10
MAC Address    EVI   VLAN  ESI                      Ether Tag  Next Hop(s)
-------------- ----- ----- ------------------------ ---------- ---------------
0000.1111.1111 10    10    0000.0000.0000.0000.0000 0          10.0.99.1
0000.2222.2222 10    10    0000.0000.0000.0000.0000 0          Gi1/0/1:10
5254.001c.c43a 10    10    0000.0000.0000.0000.0000 0          10.0.99.1

show ip mroute

vtep1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
vtep1# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag, l - LISP decap ref count contributor
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
                          t - LISP transit group
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 225.0.0.10), 00:22:08/00:02:43, RP 10.0.99.1, flags: SJCx
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet1/0/2, Forward/Sparse, 00:16:30/00:02:43, flags:
    Tunnel0, Forward/Sparse-Dense, 00:22:08/stopped, flags:

(*, 224.0.1.40), 00:22:18/00:02:45, RP 10.0.99.1, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet1/0/2, Forward/Sparse, 00:16:29/00:02:42, flags:
    Loopback0, Forward/Sparse, 00:22:16/00:02:45, flags:

vtep2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
vtep2# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag, l - LISP decap ref count contributor
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
                          t - LISP transit group
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 225.0.0.10), 00:16:37/stopped, RP 10.0.99.1, flags: SJCx
  Incoming interface: GigabitEthernet1/0/2, RPF nbr 10.0.0.1
  Outgoing interface list:
    Tunnel0, Forward/Sparse-Dense, 00:16:37/stopped, flags:

(*, 224.0.1.40), 00:16:37/00:02:26, RP 10.0.99.1, flags: SJCL
  Incoming interface: GigabitEthernet1/0/2, RPF nbr 10.0.0.1
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:16:35/00:02:26, flags:

show ip mfib

vtep1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
vtep1# show ip mfib
Entry Flags:    C - Directly Connected, S - Signal, IA - Inherit A flag,
                ET - Data Rate Exceeds Threshold, K - Keepalive
                DDE - Data Driven Event, HW - Hardware Installed
                ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
                MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
                MS  - MoFRR  Entry in Sync, MC - MoFRR entry in MoFRR Client,
                e   - Encap helper tunnel flag.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
                NS - Negate Signalling, SP - Signal Present,
                A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
                MA - MFIB Accept, A2 - Accept backup,
                RA2 - MRIB Accept backup, MA2 - MFIB Accept backup

Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts:      Total/RPF failed/Other drops
I/O Item Counts:   HW Pkt Count/FS Pkt Count/PS Pkt Count   Egress Rate in pps
Default
 (*,224.0.0.0/4) Flags: C HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   0/0/0/0, Other: 0/0/0
 (*,224.0.1.40) Flags: C HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   0/0/0/0, Other: 0/0/0
   Tunnel2 Flags: A NP
   GigabitEthernet1/0/2 Flags: F NS
     Pkts: 0/0/0    Rate: 0 pps
   Loopback0 Flags: F IC NS
     Pkts: 0/0/0    Rate: 0 pps
 (*,225.0.0.10) Flags: C HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   2/0/119/0, Other: 0/0/0
   Tunnel2 Flags: A NP
   GigabitEthernet1/0/2 Flags: F NS
     Pkts: 0/0/0    Rate: 0 pps
   Tunnel0, VXLAN Decap Flags: F NS
     Pkts: 0/0/0    Rate: 0 pps

vtep2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
vtep2# show ip mfib
Entry Flags:    C - Directly Connected, S - Signal, IA - Inherit A flag,
                ET - Data Rate Exceeds Threshold, K - Keepalive
                DDE - Data Driven Event, HW - Hardware Installed
                ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
                MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
                MS  - MoFRR  Entry in Sync, MC - MoFRR entry in MoFRR Client,
                e   - Encap helper tunnel flag.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
                NS - Negate Signalling, SP - Signal Present,
                A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
                MA - MFIB Accept, A2 - Accept backup,
                RA2 - MRIB Accept backup, MA2 - MFIB Accept backup

Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts:      Total/RPF failed/Other drops
I/O Item Counts:   HW Pkt Count/FS Pkt Count/PS Pkt Count   Egress Rate in pps
Default
 (*,224.0.0.0/4) Flags: C HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   0/0/0/0, Other: 0/0/0
 (*,224.0.1.40) Flags: C HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   0/0/0/0, Other: 0/0/0
   GigabitEthernet1/0/2 Flags: A NS
   Loopback0 Flags: F IC NS
     Pkts: 0/0/0    Rate: 0 pps
 (*,225.0.0.10) Flags: C HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   2/0/119/0, Other: 0/0/0
   GigabitEthernet1/0/2 Flags: A NS
   Tunnel0, VXLAN Decap Flags: F NS
     Pkts: 0/0/0    Rate: 0 pps
 (10.0.99.2,225.0.0.10) Flags: HW
   SW Forwarding: 0/0/0/0, Other: 0/0/0
   HW Forwarding:   0/0/0/0, Other: 0/0/0
   Null0 Flags: A
   Tunnel1 Flags: F NP
     Pkts: 0/0/0    Rate: 0 pps