Skip to content

IOS-XE / BGP / シングル RR コンフィグ例

IOS-XE を RR 構成で BGP 設定したので、コンフィグをメモしておきます。 RR はシングル構成です。

構成図

file

ノード 機種 OS
RR、PE1 〜 PE3 Catalyst8000v IOS-XE 17.10.01a
CE1 〜 CE3 IOSv IOS 15.9(3)M6

コンフィグ

RR

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
hostname RR
!
interface Loopback0
 ip address 10.0.99.9 255.255.255.255
!
interface GigabitEthernet2
 ip address 10.0.0.9 255.255.255.0
 no shutdown
!
router ospf 65000
 router-id 10.0.99.9
 network 10.0.0.0 0.0.0.255 area 0.0.0.0
 network 10.0.99.9 0.0.0.0 area 0.0.0.0
!
router bgp 65000
 bgp router-id interface Loopback0
 bgp log-neighbor-changes
 neighbor 10.0.99.1 remote-as 65000
 neighbor 10.0.99.1 update-source Loopback0
 neighbor 10.0.99.1 route-reflector-client
 neighbor 10.0.99.2 remote-as 65000
 neighbor 10.0.99.2 update-source Loopback0
 neighbor 10.0.99.2 route-reflector-client
 neighbor 10.0.99.3 remote-as 65000
 neighbor 10.0.99.3 update-source Loopback0
 neighbor 10.0.99.3 route-reflector-client
!
end

PE1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
hostname PE1
!
interface Loopback0
 ip address 10.0.99.1 255.255.255.255
!
interface GigabitEthernet2
 ip address 10.0.0.1 255.255.255.0
 no shutdown
!
interface GigabitEthernet3
 ip address 192.168.10.254 255.255.255.0
 no shutdown
!
router ospf 65000
 router-id 10.0.99.1
 passive-interface default
 no passive-interface GigabitEthernet2
 no passive-interface Loopback0
 network 0.0.0.0 255.255.255.255 area 0.0.0.0
!
router bgp 65000
 bgp router-id interface Loopback0
 neighbor 10.0.99.9 remote-as 65000
 neighbor 10.0.99.9 update-source Loopback0
 neighbor 192.168.10.1 remote-as 65010
!
end

PE2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
hostname PE2
!
interface Loopback0
 ip address 10.0.99.2 255.255.255.255
!
interface GigabitEthernet2
 ip address 10.0.0.2 255.255.255.0
 no shutdown
!
interface GigabitEthernet3
 ip address 192.168.20.254 255.255.255.0
 no shutdown
!
router ospf 65000
 router-id 10.0.99.2
 passive-interface default
 no passive-interface GigabitEthernet2
 no passive-interface Loopback0
 network 0.0.0.0 255.255.255.255 area 0.0.0.0
!
router bgp 65000
 bgp router-id interface Loopback0
 neighbor 10.0.99.9 remote-as 65000
 neighbor 10.0.99.9 update-source Loopback0
 neighbor 192.168.20.1 remote-as 65020
!
end

PE3

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
hostname PE3
!
interface Loopback0
 ip address 10.0.99.3 255.255.255.255
!
interface GigabitEthernet2
 ip address 10.0.0.3 255.255.255.0
 no shutdown
!
interface GigabitEthernet3
 ip address 192.168.30.254 255.255.255.0
 no shutdown
!
router ospf 65000
 router-id 10.0.99.3
 passive-interface default
 no passive-interface GigabitEthernet2
 no passive-interface Loopback0
 network 0.0.0.0 255.255.255.255 area 0.0.0.0
!
router bgp 65000
 bgp router-id interface Loopback0
 neighbor 10.0.99.9 remote-as 65000
 neighbor 10.0.99.9 update-source Loopback0
 neighbor 192.168.30.1 remote-as 65030
!
end

CE1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
hostname CE1
!
interface Loopback0
 ip address 192.168.99.10 255.255.255.255
!
interface Loopback11
 ip address 192.168.11.1 255.255.255.0
!
interface GigabitEthernet0/1
 ip address 192.168.10.1 255.255.255.0
 no shutdown
!
router bgp 65010
 bgp router-id interface Loopback0
 network 192.168.11.0
 neighbor 192.168.10.254 remote-as 65000
!
end

CE2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
hostname CE2
!
interface Loopback0
 ip address 192.168.99.20 255.255.255.255
!
interface Loopback21
 ip address 192.168.21.1 255.255.255.0
!
interface GigabitEthernet0/1
 ip address 192.168.20.1 255.255.255.0
 no shutdown
!
router bgp 65020
 bgp router-id interface Loopback0
 network 192.168.21.0
 neighbor 192.168.20.254 remote-as 65000
!
end

CE3

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
hostname CE3
!
interface Loopback0
 ip address 192.168.99.30 255.255.255.255
!
interface Loopback31
 ip address 192.168.31.1 255.255.255.0
!
interface GigabitEthernet0/1
 ip address 192.168.30.1 255.255.255.0
 no shutdown
!
router bgp 65030
 bgp router-id interface Loopback0
 network 192.168.31.0
 neighbor 192.168.30.254 remote-as 65000
!
end