Skip to content

ASAv での OSPF 設定例 (Broadcast / Point-to-Point)

Cisco ASA での OSPF 設定例をメモしておきます。

検証環境

対象 バージョン
ASAv 9.20(2)2
Catalyst 8000V 17.14.01a

Broadcast Network Type での OSPF 接続

Broadcast Network Type (デフォルト) での OSPF 接続設定例は以下の通りです。

IOS-XE 側の設定

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
interface GigabitEthernet1
 ip address 10.0.0.1 255.255.255.0
 ip ospf cost 100
 no shutdown
!
router ospf 65000
 router-id 1.1.1.1
 network 0.0.0.0 0.0.0.0 area 0.0.0.0
!
end

ASAv 側の設定

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
interface GigabitEthernet0/0
 no shutdown
 nameif inside
 security-level 100
 ip address 10.0.0.2 255.255.255.0
 ospf cost 100
!
router ospf 65000
 router-id 2.2.2.2
 network 0.0.0.0 0.0.0.0 area 0.0.0.0
!
end

Point-to-Point Network Type での OSPF 接続

Point-to-Point での OSPF 接続設定例は以下の通りです。 ASAv 側は Point-to-Point (ospf network point-to-point) だけだと設定出来ず、Point-to-Point Non-Broadcast (ospf network point-to-point non-broadcast) しか設定出来ません。 その為、ASAv 側では OSPF プロセス内に neighbor 10.0.0.1 interface inside のように「Neighbor 先のアドレス」を静的に指定する必要があります。

IOS-XE 側の設定

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
interface GigabitEthernet1
 ip address 10.0.0.1 255.255.255.0
 ip ospf network point-to-point
 ip ospf cost 100
 no shutdown
!
router ospf 65000
 router-id 1.1.1.1
 network 0.0.0.0 0.0.0.0 area 0.0.0.0
!
end

ASAv 側の設定

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
interface GigabitEthernet0/0
 no shutdown
 nameif inside
 security-level 100
 ip address 10.0.0.2 255.255.255.0
 ospf cost 100
 ospf network point-to-point non-broadcast
!
router ospf 65000
 router-id 2.2.2.2
 network 0.0.0.0 0.0.0.0 area 0.0.0.0
 neighbor 10.0.0.1 interface inside
!
end