Skip to content

CML 用の検証コンフィグ・テンプレート (2025/03/20 版)

以前に下記のメモを書きました。

改めて CML 上での利用を想定した「各機器の検証用コンフィグ・テンプレート」をメモしておきます。

初回 流し込みコンフィグ例 (管理 IP アドレス無し)

Cisco IOL-XE

ポイント

行数 説明
15 〜 16 コンソール接続時のタイムアウトを無効化し、ログイン直後から管理者権限を付与
20 〜 21 TELNET / SSH 接続時のタイムアウトを無効化し、ログイン直後から管理者権限を付与
22 ログイン認証の無効化
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
enable
terminal length 0
configure terminal
!
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
!
logging buffered 65536 debugging
!
clock timezone JST 9 0
!
no ip domain lookup
!
line con 0
 exec-timeout 0 0
 privilege level 15
 length 0
!
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 no login
 length 0
 transport input all
!
end

Cisco IOS-XE (Catalyst8000v & CSR1000v)

ポイント

行数 説明
19 ライセンスレベルを DNA-PREMIER へ変更する
20 スループットを 250MB へ増やす
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
enable
terminal length 0
configure terminal
!
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
!
logging buffered 65536 debugging
!
clock timezone JST 9 0
!
no ip domain lookup
!
no crypto pki certificate chain SLA-TrustPoint
yes
no crypto pki trustpoint SLA-TrustPoint
yes
!
license boot level network-premier addon dna-premier
platform hardware throughput level MB 250
!
line con 0
 exec-timeout 0 0
 privilege level 15
 length 0
!
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 no login
 length 0
 transport input all
!
end
!
write memory 
reload

Cisco IOS (IOSv & IOSvL2)

ポイント

行数 説明
11 IOS-XE とは異なり、no ip domain-lookup のようにハイフンが入る
12 〜 15 バナーを削除
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
enable
terminal length 0
configure terminal
!
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
!
logging buffered 65536 debugging
!
clock timezone JST 9 0
!
no ip domain-lookup
no banner exec ^C
no banner incoming ^C
no banner login ^C
!
line con 0
 exec-timeout 0 0
 privilege level 15
 length 0
!
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 no login
 length 0
 transport input all
!
end

初期コンフィグ例

Cisco ASAv

ポイント

行数 説明
1 ホスト名を ASAv に設定出来ない為、別の名前 (ASAv1) を設定
8 TELNET 接続に必要である為、security-level 100 を設定
27 TELNET タイムアウトを無制限に出来ない為、最大値である 1440 を設定
29 SSH タイムアウトを無制限に出来ない為、最大値である 60 を設定
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
hostname ASAv1
!
enable password password
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 10.0.0.1 255.255.255.0
 no shutdown
!
clock timezone JST 9
!
no pager
!
logging enable
logging timestamp
logging buffer-size 512000
logging buffered debugging
!
route management 0.0.0.0 0.0.0.0 10.0.0.254
!
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
!
telnet 0.0.0.0 0.0.0.0 management
telnet timeout 1440
!
ssh timeout 60
ssh version 2
ssh key-exchange group dh-group14-sha256
ssh 0.0.0.0 0.0.0.0 management
!
console timeout 0
!
username admin password password privilege 15
!
fixup protocol icmp
!
policy-map global_policy
 class inspection_default
  inspect icmp
!
no service call-home
clear config call-home
!
end

Cisco IOL-XE

ポイント

行数 説明
15 〜 16 コンソール接続時のタイムアウトを無効化し、ログイン直後から管理者権限を付与
20 〜 21 TELNET / SSH 接続時のタイムアウトを無効化し、ログイン直後から管理者権限を付与
22 ログイン認証の無効化
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
!
hostname IOL-XE
!
logging buffered 65536 debugging
!
clock timezone JST 9 0
!
no ip domain lookup
!
interface GigabitEthernet1
 ip address 10.0.0.1 255.255.255.0
 no shutdown
!
ip route 0.0.0.0 0.0.0.0 10.0.0.254
!
line con 0
 exec-timeout 0 0
 privilege level 15
 length 0
!
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 no login
 length 0
 transport input all
!
end

Cisco IOS-XE (Catalyst8000v & CSR1000v)

ポイント

行数 説明
14 ライセンスレベルを DNA-PREMIER へ変更する
15 スループットを 250MB へ増やす
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
platform console serial
!
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
!
hostname IOS-XE
!
logging buffered 65536 debugging
!
clock timezone JST 9 0
!
no ip domain lookup
!
license boot level network-premier addon dna-premier
platform hardware throughput level MB 250
!
line con 0
 exec-timeout 0 0
 privilege level 15
 length 0
!
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 no login
 length 0
 transport input all
!
end

Cisco IOS (IOSv & IOSvL2)

ポイント

行数 説明
10 IOS-XE とは異なり、no ip domain-lookup のようにハイフンが入る
32 〜 39 EEM でバナーを削除
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
!
hostname IOSv
!
logging buffered 65536 debugging
!
clock timezone JST 9 0
!
no ip domain-lookup
!
interface GigabitEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 no shutdown
!
ip route 0.0.0.0 0.0.0.0 10.0.0.254
ip ssh version 2
!
line con 0
 exec-timeout 0 0
 privilege level 15
 length 0
!
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
 length 0
 transport input all
!
event manager applet FINISING_UP
 event syslog pattern "%PLATFORM-5-SIGNATURE_VERIFIED"
 action 1.0 cli command "enable"
 action 2.0 cli command "configure terminal"
 action 3.0 cli command "no banner exec ^C"
 action 4.0 cli command "no banner incoming ^C"
 action 5.0 cli command "no banner login ^C"
 action 6.0 cli command "no event manager applet FINISING_UP"
!
end

NX-OS 9000v

ポイント

行数 説明
1-19 起動時にブートローダーへ落ちてしまう問題を回避する為のワークアラウンドを残しておく
25 TELNET を有効化
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
# workaround for booting to loader> prompt
echo 'from cli import cli' > set_boot.py
echo 'import json' >> set_boot.py
echo 'import os' >> set_boot.py
echo 'import time' >> set_boot.py
echo 'bootimage = json.loads(cli("show version | json"))["nxos_file_name"]' >> set_boot.py
echo 'set_boot = cli("conf t ; boot nxos {} ; no event manager applet BOOTCONFIG".format(bootimage))' >> set_boot.py
echo 'i = 0' >> set_boot.py
echo 'while i < 10:' >> set_boot.py
echo '    try:' >> set_boot.py
echo '        save_config = cli("copy running-config startup-config")' >> set_boot.py
echo '        break' >> set_boot.py
echo '    except Exception:' >> set_boot.py
echo '        i += 1' >> set_boot.py
echo '        time.sleep(1)' >> set_boot.py
echo 'os.remove("/bootflash/set_boot.py")' >> set_boot.py
event manager applet BOOTCONFIG
 event syslog pattern "Configured from vty"
 action 1.0 cli python bootflash:set_boot.py
# minimum needed config to login
license grace-period
!
hostname NX-OSv
!
feature telnet
!
clock timezone JST 9 0
!
no password strength-check
username admin role network-admin
username admin password password role network-admin
!
vrf context management
  ip route 0.0.0.0/0 mgmt0 10.0.0.254
!
line console
  exec-timeout 0
  terminal length 0
!
interface mgmt0
  vrf member management
  ip address 10.0.0.1/24
  no shutdown
!
line vty
  exec-timeout 0
!
logging timestamp milliseconds
!
end