Skip to content

IOSv / XEv / XRv / Junos で BMP を試してみる

BMP とは「BGP Monitoring Protocol」のことで、現在は標準化に向けて IETF のドラフト段階 (draft-17) にあります。

BMP サーバの実装はまだ数が少ないようですが、今回は ryu に付随する BMP サーバを IOSv、XEv、XRv、Junos と組み合わせて試してみます。

NX-OSv も試してみたのですが、後述の通り BMP の設定が出来ませんでした。

検証環境

構成

VIRL 上で以下の構成を作り、検証しました。10.1.0.0/24 側のネットワークは BMP サーバ/クライアント間の通信用、10.2.0.0/24 側のネットワークは eBGP Peering 用です。

file

BMP サーバは Ubuntu を使いました。BMP サーバをインストールする為、インターネットへ接続出来るようにしておきます。

1
2
3
4
5
$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.2 LTS"

クライアント側は以下の OS を使いました。

ルータ バージョン
IOSv 15.6(1)
CSR 1000v (IOS-XE) 15.6(1)S
IOS-XRv 6.0.0
NX-OSv 7.2(0)D1(1)
Junos 14.1R1.10

Linux の設定

BMP クライアントと接続するインターフェイスのアドレスだけ、設定しておきます。BMP サーバは後の手順でインストールします。

1
2
sudo ip addr add 10.1.0.100/24 dev eth1
sudo ip link set up dev eth1

IOSv の設定

デフォルトでは BMP サーバとのコネクションを開始する値を示す initial-delay が 600 秒になっていました。検証環境では早めに BMP サーバとコネクションを確立して欲しいので、initial-delay 30 を設定してあります。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
hostname IOSv
!
interface GigabitEthernet0/1
 ip address 10.1.0.1 255.255.255.0
 no shutdown
!
interface GigabitEthernet0/2
 ip address 10.2.0.1 255.255.255.0
 no shutdown
!
router bgp 65001
 bmp server 1
  initial-delay 30
  address 10.1.0.100 port-number 11019
  activate
 exit-bmp-server-mode
 !
 bgp router-id 10.2.0.1
 neighbor 10.2.0.2 remote-as 65002
 neighbor 10.2.0.3 remote-as 65003
 neighbor 10.2.0.4 remote-as 65004
 neighbor 10.2.0.5 remote-as 65005
 neighbor 10.2.0.5 bmp-activate server 1
!
end

CSR1000v の設定

IOSv 同様に initial-delay 30 を設定してあります。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
hostname CSR1000v
!
interface GigabitEthernet2
 ip address 10.1.0.2 255.255.255.0
 no shutdown
!
interface GigabitEthernet3
 ip address 10.2.0.2 255.255.255.0
 no shutdown
!
router bgp 65002
 bmp server 1
  address 10.1.0.100 port-number 11019
  initial-delay 30
  activate
 exit-bmp-server-mode
 !
 bgp router-id 10.2.0.2
 bgp log-neighbor-changes
 neighbor 10.2.0.1 remote-as 65001
 neighbor 10.2.0.1 bmp-activate server 1
 neighbor 10.2.0.3 remote-as 65003
 neighbor 10.2.0.4 remote-as 65004
 neighbor 10.2.0.5 remote-as 65005
!
end

XRv の設定

IOSv 同様に initial-delay 30 を設定してあります。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
hostname XRv
!
interface GigabitEthernet0/0/0/0
 ipv4 address 10.1.0.3/24
 no shutdown
!
interface GigabitEthernet0/0/0/1
 ipv4 address 10.2.0.3/24
 no shutdown
!
router bgp 65003
 bgp router-id 10.2.0.3
 address-family ipv4 unicast
 !
 neighbor 10.2.0.1
  remote-as 65001
  bmp-activate server 1
  address-family ipv4 unicast
 !
 neighbor 10.2.0.2
  remote-as 65002
  address-family ipv4 unicast
 !
 neighbor 10.2.0.4
  remote-as 65004
  address-family ipv4 unicast
 !
 neighbor 10.2.0.5
  remote-as 65005
  address-family ipv4 unicast
 !
!
bmp server 1
 host 10.1.0.100 port 11019
 initial-delay 30
!
end

NX-OSv

BGP 機能を使う為、license grace-period で評価ライセンスを有効化しておきます。

1
switch(config)# license grace-period

インターフェイスや BGP の設定は以下の通りです。しかし、Cisco の公式サイトを調べたのですが、現状の NX-OS では BMP がサポートされていないのか、設定コマンドを見つけることが出来ませんでした。2014/9/16 公開の BGP Monitoring Protocol の P.6 には「N3K, N7K, N9K: TBD」と記載されていました。もしかすると現時点でも NX-OS では BMP が未実装なのかも知れません。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
hostname NX-OSv
!
interface Ethernet2/1
  no switchport
  ip address 10.1.0.4/24
  no shutdown
!
interface Ethernet2/2
  no switchport
  ip address 10.2.0.4/24
  no shutdown
!
router bgp 65004
  router-id 10.2.0.4
  address-family ipv4 unicast
  neighbor 10.2.0.1 remote-as 65001
    address-family ipv4 unicast
  neighbor 10.2.0.1 remote-as 65001
    address-family ipv4 unicast
  neighbor 10.2.0.2 remote-as 65002
    address-family ipv4 unicast
  neighbor 10.2.0.3 remote-as 65003
    address-family ipv4 unicast
  neighbor 10.2.0.5 remote-as 65005
    address-family ipv4 unicast
!
end

Junos

Cisco の initial-delay に該当するコマンドは見つけられませんでした。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
set system host-name Junos
set interfaces em1 unit 0 family inet address 10.1.0.5/24
set interfaces em2 unit 0 family inet address 10.2.0.5/24
set routing-options bmp station-address 10.1.0.100
set routing-options bmp station SERVER-1 connection-mode active
set routing-options bmp station SERVER-1 station-address 10.1.0.100
set routing-options bmp station SERVER-1 station-port 11019
set protocols bgp local-as 65005
set protocols bgp group BMP-TEST neighbor 10.2.0.1 peer-as 65001
set protocols bgp group BMP-TEST neighbor 10.2.0.1 bmp monitor enable
set protocols bgp group BMP-TEST neighbor 10.2.0.1 bmp route-monitoring pre-policy exclude-non-feasible
set protocols bgp group BMP-TEST neighbor 10.2.0.1 bmp route-monitoring post-policy exclude-non-eligible
set protocols bgp group BMP-TEST neighbor 10.2.0.2 peer-as 65002
set protocols bgp group BMP-TEST neighbor 10.2.0.3 peer-as 65003
set protocols bgp group BMP-TEST neighbor 10.2.0.4 peer-as 65004

ryu のインストール

ryu をインストールします。

1
2
3
4
5
sudo apt-get update
sudo apt-get -y install unzip build-essential libexpat1-dev libgmp-dev libncurses5-dev libssl-dev libpcap-dev byacc flex libreadline-dev python-dev python-pastedeploy python-paste python-twisted git python-setuptools python-pip libxml2-dev libxslt1-dev ethtool

sudo pip install ryu
sudo pip install six --upgrade

BMP サーバを起動します。デフォルトでは 11,019/TCP を Listen します。

1
ryu-manager --verbose /usr/local/lib/python2.7/dist-packages/ryu/app/bmpstation.py

実際には以下のようなログが出力されました。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
2016 Apr 03 16:56:47 | 10.1.0.2 | BMPPeerUpNotification(is_post_policy=False,len=182,local_address='0.0.0.0',local_port=179,peer_address='0.0.0.0',peer_as=65001,peer_bgp_id='10.2.0.1',peer_distinguisher=0,peer_type=0,received_open_message=BGPOpen(bgp_identifier='10.2.0.1',hold_time=180,len=57,my_as=65001,opt_param=[BGPOptParamCapabilityMultiprotocol(afi=1,cap_code=1,cap_length=4,length=6,reserved=0,safi=1,type=2), BGPOptParamCapabilityRouteRefresh(cap_code=2,cap_length=0,length=2,type=2), BGPOptParamCapabilityCiscoRouteRefresh(cap_code=128,cap_length=0,length=2,type=2), BGPOptParamCapabilityEnhancedRouteRefresh(cap_code=70,cap_length=0,length=2,type=2), BGPOptParamCapabilityFourOctetAsNumber(as_number=65001,cap_code=65,cap_length=4,length=6,type=2)],opt_param_len=28,type=1,version=4),remote_port=29088,sent_open_message=BGPOpen(bgp_identifier='10.2.0.2',hold_time=180,len=57,my_as=65002,opt_param=[BGPOptParamCapabilityMultiprotocol(afi=1,cap_code=1,cap_length=4,length=6,reserved=0,safi=1,type=2), BGPOptParamCapabilityCiscoRouteRefresh(cap_code=128,cap_length=0,length=2,type=2), BGPOptParamCapabilityRouteRefresh(cap_code=2,cap_length=0,length=2,type=2), BGPOptParamCapabilityEnhancedRouteRefresh(cap_code=70,cap_length=0,length=2,type=2), BGPOptParamCapabilityFourOctetAsNumber(as_number=65002,cap_code=65,cap_length=4,length=6,type=2)],opt_param_len=28,type=1,version=4),timestamp=0.0,type=3,version=3)

2016 Apr 03 16:56:52 | 10.1.0.3 | BMPPeerUpNotification(is_post_policy=False,len=178,local_address='0.0.0.0',local_port=179,peer_address='0.0.0.0',peer_as=65001,peer_bgp_id='0.0.0.0',peer_distinguisher=0,peer_type=0,received_open_message=BGPOpen(bgp_identifier='10.2.0.1',hold_time=180,len=57,my_as=65001,opt_param=[BGPOptParamCapabilityMultiprotocol(afi=1,cap_code=1,cap_length=4,length=6,reserved=0,safi=1,type=2), BGPOptParamCapabilityCiscoRouteRefresh(cap_code=128,cap_length=0,length=2,type=2), BGPOptParamCapabilityRouteRefresh(cap_code=2,cap_length=0,length=2,type=2), BGPOptParamCapabilityEnhancedRouteRefresh(cap_code=70,cap_length=0,length=2,type=2), BGPOptParamCapabilityFourOctetAsNumber(as_number=65001,cap_code=65,cap_length=4,length=6,type=2)],opt_param_len=28,type=1,version=4),remote_port=62538,sent_open_message=BGPOpen(bgp_identifier='10.2.0.3',hold_time=180,len=53,my_as=65003,opt_param=[BGPOptParamCapabilityMultiprotocol(afi=1,cap_code=1,cap_length=4,length=6,reserved=0,safi=1,type=2), BGPOptParamCapabilityCiscoRouteRefresh(cap_code=128,cap_length=0,length=2,type=2), BGPOptParamCapabilityRouteRefresh(cap_code=2,cap_length=0,length=2,type=2), BGPOptParamCapabilityFourOctetAsNumber(as_number=65003,cap_code=65,cap_length=4,length=6,type=2)],opt_param_len=24,type=1,version=4),timestamp=1459702611.490027,type=3,version=3)

2016 Apr 03 16:56:53 | 10.1.0.5 | BMPPeerUpNotification(is_post_policy=False,len=184,local_address='0.0.0.0',local_port=179,peer_address='0.0.0.0',peer_as=65001,peer_bgp_id='10.2.0.1',peer_distinguisher=0,peer_type=0,received_open_message=BGPOpen(bgp_identifier='10.2.0.1',hold_time=180,len=57,my_as=65001,opt_param=[BGPOptParamCapabilityMultiprotocol(afi=1,cap_code=1,cap_length=4,length=6,reserved=0,safi=1,type=2), BGPOptParamCapabilityCiscoRouteRefresh(cap_code=128,cap_length=0,length=2,type=2), BGPOptParamCapabilityRouteRefresh(cap_code=2,cap_length=0,length=2,type=2), BGPOptParamCapabilityEnhancedRouteRefresh(cap_code=70,cap_length=0,length=2,type=2), BGPOptParamCapabilityFourOctetAsNumber(as_number=65001,cap_code=65,cap_length=4,length=6,type=2)],opt_param_len=28,type=1,version=4),remote_port=35277,sent_open_message=BGPOpen(bgp_identifier='10.1.0.5',hold_time=90,len=59,my_as=65005,opt_param=[BGPOptParamCapabilityMultiprotocol(afi=1,cap_code=1,cap_length=4,length=6,reserved=0,safi=1,type=2), BGPOptParamCapabilityCiscoRouteRefresh(cap_code=128,cap_length=0,length=2,type=2), BGPOptParamCapabilityRouteRefresh(cap_code=2,cap_length=0,length=2,type=2), BGPOptParamCapabilityGracefulRestart(cap_code=64,cap_length=2,flags=0,length=4,time=120,tuples=[],type=2), BGPOptParamCapabilityFourOctetAsNumber(as_number=65005,cap_code=65,cap_length=4,length=6,type=2)],opt_param_len=30,type=1,version=4),timestamp=1459702612.0,type=3,version=3)

2016 Apr 03 16:56:53 | 10.1.0.5 | BMPStatisticsReport(is_post_policy=False,len=132,peer_address='0.0.0.0',peer_as=65001,peer_bgp_id='10.2.0.1',peer_distinguisher=0,peer_type=0,stats=[{'type': 0, 'value': 0, 'len': 4}, {'type': 1, 'value': 0, 'len': 4}, {'type': 2, 'value': 0, 'len': 4}, {'type': 3, 'value': 0, 'len': 4}, {'type': 4, 'value': 0, 'len': 4}, {'type': 5, 'value': 0, 'len': 4}, {'type': 6, 'value': 0, 'len': 4}, {'type': 7, 'value': 0, 'len': 8}, {'type': 8, 'value': 0, 'len': 8}],timestamp=1459702612.0,type=1,version=3)

2016 Apr 03 16:56:53 | 10.1.0.5 | BMPRouteMonitoring(bgp_update=BGPUpdate(len=23,nlri=[],path_attributes=[],total_path_attribute_len=0,type=2,withdrawn_routes=[],withdrawn_routes_len=0),is_post_policy=False,len=71,peer_address='0.0.0.0',peer_as=65001,peer_bgp_id='10.2.0.1',peer_distinguisher=0,peer_type=0,timestamp=1459702612.0,type=0,version=3)

2016 Apr 03 16:56:53 | 10.1.0.5 | BMPRouteMonitoring(bgp_update=BGPUpdate(len=23,nlri=[],path_attributes=[],total_path_attribute_len=0,type=2,withdrawn_routes=[],withdrawn_routes_len=0),is_post_policy=True,len=71,peer_address='0.0.0.0',peer_as=65001,peer_bgp_id='10.2.0.1',peer_distinguisher=0,peer_type=0,timestamp=1459702612.0,type=0,version=3)

2016 Apr 03 16:56:53 | 10.1.0.1 | BMPPeerUpNotification(is_post_policy=False,len=184,local_address='0.0.0.0',local_port=35277,peer_address='0.0.0.0',peer_as=65005,peer_bgp_id='10.1.0.5',peer_distinguisher=0,peer_type=0,received_open_message=BGPOpen(bgp_identifier='10.1.0.5',hold_time=90,len=59,my_as=65005,opt_param=[BGPOptParamCapabilityMultiprotocol(afi=1,cap_code=1,cap_length=4,length=6,reserved=0,safi=1,type=2), BGPOptParamCapabilityRouteRefresh(cap_code=2,cap_length=0,length=2,type=2), BGPOptParamCapabilityCiscoRouteRefresh(cap_code=128,cap_length=0,length=2,type=2), BGPOptParamCapabilityGracefulRestart(cap_code=64,cap_length=2,flags=0,length=4,time=120,tuples=[],type=2), BGPOptParamCapabilityFourOctetAsNumber(as_number=65005,cap_code=65,cap_length=4,length=6,type=2)],opt_param_len=30,type=1,version=4),remote_port=179,sent_open_message=BGPOpen(bgp_identifier='10.2.0.1',hold_time=180,len=57,my_as=65001,opt_param=[BGPOptParamCapabilityMultiprotocol(afi=1,cap_code=1,cap_length=4,length=6,reserved=0,safi=1,type=2), BGPOptParamCapabilityCiscoRouteRefresh(cap_code=128,cap_length=0,length=2,type=2), BGPOptParamCapabilityRouteRefresh(cap_code=2,cap_length=0,length=2,type=2), BGPOptParamCapabilityEnhancedRouteRefresh(cap_code=70,cap_length=0,length=2,type=2), BGPOptParamCapabilityFourOctetAsNumber(as_number=65001,cap_code=65,cap_length=4,length=6,type=2)],opt_param_len=28,type=1,version=4),timestamp=0.0,type=3,version=3)

2016 Apr 03 16:56:53 | 10.1.0.1 | BMPRouteMonitoring(bgp_update=BGPUpdate(len=56,nlri=[BGPNLRI(addr='10.0.0.1',length=32)],path_attributes=[BGPPathAttributeOrigin(flags=64,length=1,type=1,value=0), BGPPathAttributeAsPath(flags=64,length=14,type=2,value=[[65005, 65002, 65001]]), BGPPathAttributeNextHop(flags=64,length=4,type=3,value='10.2.0.1')],total_path_attribute_len=28,type=2,withdrawn_routes=[],withdrawn_routes_len=0),is_post_policy=False,len=104,peer_address='0.0.0.0',peer_as=65005,peer_bgp_id='10.1.0.5',peer_distinguisher=0,peer_type=0,timestamp=0.0,type=0,version=3)

2016 Apr 03 16:56:56 | 10.1.0.5 | BMPRouteMonitoring(bgp_update=BGPUpdate(len=28,nlri=[],path_attributes=[],total_path_attribute_len=0,type=2,withdrawn_routes=[BGPWithdrawnRoute(addr='10.0.0.1',length=32)],withdrawn_routes_len=5),is_post_policy=False,len=76,peer_address='0.0.0.0',peer_as=65004,peer_bgp_id='10.2.0.4',peer_distinguisher=0,peer_type=0,timestamp=1459702614.0,type=0,version=3)

2016 Apr 03 16:56:56 | 10.1.0.5 | BMPRouteMonitoring(bgp_update=BGPUpdate(len=28,nlri=[],path_attributes=[],total_path_attribute_len=0,type=2,withdrawn_routes=[BGPWithdrawnRoute(addr='10.0.0.1',length=32)],withdrawn_routes_len=5),is_post_policy=False,len=76,peer_address='0.0.0.0',peer_as=65002,peer_bgp_id='10.2.0.2',peer_distinguisher=0,peer_type=0,timestamp=1459702614.0,type=0,version=3)

2016 Apr 03 16:56:56 | 10.1.0.1 | BMPRouteMonitoring(bgp_update=BGPUpdate(len=28,nlri=[],path_attributes=[],total_path_attribute_len=0,type=2,withdrawn_routes=[BGPWithdrawnRoute(addr='10.0.0.1',length=32)],withdrawn_routes_len=5),is_post_policy=False,len=76,peer_address='0.0.0.0',peer_as=65005,peer_bgp_id='10.1.0.5',peer_distinguisher=0,peer_type=0,timestamp=0.0,type=0,version=3)

2016 Apr 03 16:57:57 | 10.1.0.2 | BMPRouteMonitoring(bgp_update=BGPUpdate(len=23,nlri=[],path_attributes=[],total_path_attribute_len=0,type=2,withdrawn_routes=[],withdrawn_routes_len=0),is_post_policy=False,len=71,peer_address='0.0.0.0',peer_as=65001,peer_bgp_id='10.2.0.1',peer_distinguisher=0,peer_type=0,timestamp=0.0,type=0,version=3)

2016 Apr 03 16:57:57 | 10.1.0.3 | BMPRouteMonitoring(bgp_update=BGPUpdate(len=23,nlri=[],path_attributes=[],total_path_attribute_len=0,type=2,withdrawn_routes=[],withdrawn_routes_len=0),is_post_policy=False,len=71,peer_address='0.0.0.0',peer_as=65001,peer_bgp_id='10.2.0.1',peer_distinguisher=0,peer_type=0,timestamp=1459702676.745556,type=0,version=3)

ネットワーク機器側での状態確認

IOSv

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
IOSv# show ip bgp bmp server summary
Number of BMP servers configured: 1
Number of BMP neighbors configured: 1
Number of neighbors on TransitionQ: 0, MonitoringQ: 0, ConfigQ: 0
Number of BMP servers on StatsQ: 0
BMP Refresh not in progress, refresh not scheduled
Initial Refresh Delay not configured
BMP buffer size not configured

ID Host/Net          Port  TCB                 Status  Uptime    MsgSent   LastStat
1  10.1.0.100        11019 0xE476B38           Up      00:06:05  7
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
IOSv# show ip bgp bmp server 1

bmp server 1
    address: 10.1.0.100    port 11019
    up time 00:06:12
    initial-delay 30
    failure-retry-delay 600
    flapping-delay 1800
    activated
    Writeblocked count: 0
    Writecleared count: 0
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 10.1.0.1, Local port: 42523
Foreign host: 10.1.0.100, Foreign port: 11019
Connection tableid (VRF): 0
Maximum output segment queue size: 50

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0xC2F0C4):
Timer          Starts    Wakeups            Next
Retrans             8          0             0x0
TimeWait            0          0             0x0
AckHold             1          0             0x0
SendWnd             0          0             0x0
KeepAlive          52          0        0xC30B3A
GiveUp              0          0             0x0
PmtuAger            1          0        0xC66881
DeadWait            0          0             0x0
Linger              0          0             0x0
ProcessQ            0          0             0x0

iss:  901755541  snduna:  901756242  sndnxt:  901756242
irs: 1295173891  rcvnxt: 1295173892

sndwnd:  31088  scale:      0  maxrcvwnd:  16384
rcvwnd:  16384  scale:      0  delrcvwnd:      0

SRTT: 656 ms, RTTO: 2806 ms, RTV: 2150 ms, KRTT: 0 ms
minRTT: 3 ms, maxRTT: 1000 ms, ACK hold: 200 ms
uptime: 372740 ms, Sent idletime: 8229 ms, Receive idletime: 8226 ms
Status Flags: active open
Option Flags: keepalive running, nagle, path mtu capable
IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):
Rcvd: 30 (out of order: 0), with data: 0, total data bytes: 0
Sent: 31 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 7, total data bytes: 700

 Packets received in fast path: 0, fast processed: 0, slow path: 0
 fast lock acquisition failures: 0, slow path: 0
TCP Semaphore      0x0C02BD6C  FREE

CSR1000v

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
CSR1000v# show ip bgp bmp server summary
Number of BMP servers configured: 1
Number of BMP neighbors configured: 1
Number of neighbors on TransitionQ: 0, MonitoringQ: 0, ConfigQ: 0
Number of BMP servers on StatsQ: 0
BMP Refresh not in progress, refresh not scheduled
Initial Refresh Delay not configured
BMP buffer size not configured

ID Host/Net          Port  TCB                 Status  Uptime    MsgSent   LastStat
1  10.1.0.100        11019 0x7F1EFEB96AE0      Up      00:07:35  9
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
CSR1000v# show ip bgp bmp server 1

bmp server 1
    address: 10.1.0.100    port 11019
    up time 00:08:21
    initial-delay 30
    failure-retry-delay 600
    flapping-delay 1800
    activated
    Writeblocked count: 0
    Writecleared count: 0
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 10.1.0.2, Local port: 29041
Foreign host: 10.1.0.100, Foreign port: 11019
Connection tableid (VRF): 0
Maximum output segment queue size: 50

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0xC6879F):
Timer          Starts    Wakeups            Next
Retrans             8          0             0x0
TimeWait            0          0             0x0

AckHold             1          0             0x0
SendWnd             0          0             0x0
KeepAlive          70          0        0xC6AFEA
GiveUp              0          0             0x0
PmtuAger            1          0        0xC80A32
DeadWait            0          0             0x0
Linger              0          0             0x0
ProcessQ            0          0             0x0

iss: 3900313001  snduna: 3900313829  sndnxt: 3900313829
irs: 3951823571  rcvnxt: 3951823572

sndwnd:  32160  scale:      0  maxrcvwnd:  16384
rcvwnd:  16384  scale:      0  delrcvwnd:      0

SRTT: 656 ms, RTTO: 2806 ms, RTV: 2150 ms, KRTT: 0 ms
minRTT: 1 ms, maxRTT: 1000 ms, ACK hold: 200 ms
uptime: 501039 ms, Sent idletime: 4688 ms, Receive idletime: 4685 ms
Status Flags: active open
Option Flags: keepalive running, nagle, path mtu capable
IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):

Rcvd: 39 (out of order: 0), with data: 0, total data bytes: 0
Sent: 40 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 7, total data bytes: 827

 Packets received in fast path: 0, fast processed: 0, slow path: 0
 fast lock acquisition failures: 0, slow path: 0
TCP Semaphore      0x7F1F1B8ABAE0  FREE

XRv

1
2
3
4
RP/0/0/CPU0:XRv# show bgp bmp summary
Sun Apr  3 17:04:54.176 UTC
ID   Host                 Port     State   Time        NBRs
 1   10.1.0.100           11019    ESTAB   00:10:35    1
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
RP/0/0/CPU0:XRv# show bgp bmp server 1
Sun Apr  3 17:05:14.605 UTC
BMP server 1
Host 10.1.0.100 Port 11019
Connected for 00:10:56
Precedence:  internet
BGP neighbors: 1
VRF: - (0x60000000)
Update Source: - (-)
Update Source Vrf ID: 0x0

Message Stats:
Total messages sent: 11
         INITIATION: 1
        TERMINATION: 0
       STATS-REPORT: 0
  PER-PEER messages: 10

  Neighbor 10.2.0.1
Messages pending: 0
Messages sent: 10
      PEER-UP: 4
    PEER-DOWN: 2
    ROUTE-MON: 4

Junos

terse や summary に該当するコマンドは存在しないようで、一覧で状態を確認することは出来ませんでした。

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
root@Junos> show bgp bmp SERVER-1
Station name: SERVER-1
  Local address/port: -/-, Station address/port: 10.1.0.100/11019, active
  State: established Local: 10.1.0.5+59364 Remote: 10.1.0.100+11019
  Last state change: 11:03
  Monitor BGP Peers: enabled
  Route-monitoring: pre-policy
  Hold-down: 600, flaps 3, period 300
  Priority: low
  Statistics timeout: 3600
  Version: 3

(ほぼ) 初期状態での状態確認

アドレスだけ設定した状態で、各 OS の BMP 状態確認コマンドを実行してみました。

IOSv

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
IOSv# show ip bgp bmp server details

 print detailed info for all servers
bmp server 1
    address: 10.1.0.100    port 11019
    down time never
    initial-delay 600
    failure-retry-delay 600
    flapping-delay 1800
    Writeblocked count: 0
    Writecleared count: 0
    No active TCP connection

CSR1000v

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
CSR1000v# show ip bgp bmp server details

 print detailed info for all servers
bmp server 1
    address: 10.1.0.100    port 11019
    down time never
    initial-delay 600
    failure-retry-delay 600
    flapping-delay 1800
    Writeblocked count: 0
    Writecleared count: 0
    No active TCP connection

XRv

show bgp bmp server を実行しても、タイムアウト値等が表示されません。detail を指定しても、表示結果は全く変わりませんでした…??

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
RP/0/0/CPU0:XRv# show bgp bmp server 1
Sun Apr  3 13:59:21.639 UTC
BMP server 1
Host 10.1.0.100 Port 11019
NOT Connected
Precedence:  internet
BGP neighbors: 0
VRF: - (0x60000000)
Update Source: - (-)
Update Source Vrf ID: 0x0

Message Stats:
Total messages sent: 0
         INITIATION: 0
        TERMINATION: 0
       STATS-REPORT: 0
  PER-PEER messages: 0
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
RP/0/0/CPU0:XRv# show bgp bmp server 1 detail
Sun Apr  3 13:59:29.319 UTC
BMP server 1
Host 10.1.0.100 Port 11019
NOT Connected
Precedence:  internet
BGP neighbors: 0
VRF: - (0x60000000)
Update Source: - (-)
Update Source Vrf ID: 0x0

Message Stats:
Total messages sent: 0
         INITIATION: 0
        TERMINATION: 0
       STATS-REPORT: 0
  PER-PEER messages: 0

Junos

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
root@Junos> show bgp bmp SERVER-1
Station name: SERVER-1
  Local address/port: -/-, Station address/port: 10.1.0.100/11019, active
  State: connect-timer Retry connect in 22 seconds
  Last state change: 1:50
  Monitor BGP Peers: enabled
  Route-monitoring: pre-policy
  Hold-down: 600, flaps 3, period 300
  Priority: low
  Statistics timeout: 3600
  Version: 3

参考リンク

IOS-XR については、参考になるドキュメントが見つかりませんでした。

参考