Skip to content

IOS-XE (IOL) で IPv6 + EIGRP を設定する

IOS-XE で動作する IOL を使い、IPv6 + EIGRP を構成したコンフィグ例などをメモしておきます。

検証環境

対象 バージョン
IOS-XE 17.12.1

構成図

file

コンフィグ

dev1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
hostname dev1
!
ipv6 unicast-routing
!
interface Ethernet0/1
 shutdown
!
interface Ethernet0/2
 no ip address
 ipv6 address 2001:DB8:0:1::81/64
 ipv6 eigrp 65000
 no shutdown
!
ipv6 router eigrp 65000
 passive-interface default
 no passive-interface Ethernet0/2
 eigrp router-id 1.1.1.1
!
end

dev2

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
hostname dev2
!
ipv6 unicast-routing
!
interface Ethernet0/1
 no ip address
 ipv6 address 2001:DB8:0:12::2/64
 ipv6 eigrp 65000
 no shutdown
!
interface Ethernet0/2
 no ip address
 ipv6 address 2001:DB8:0:23::2/64
 ipv6 eigrp 65000
 no shutdown
!
ipv6 router eigrp 65000
 passive-interface default
 no passive-interface Ethernet0/1
 no passive-interface Ethernet0/2
 eigrp router-id 2.2.2.2
!
end

dev3

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
hostname dev3
!
ipv6 unicast-routing
!
interface Ethernet0/1
 no ip address
 ipv6 address 2001:DB8:0:23::3/64
 ipv6 eigrp 65000
 no shutdown
!
interface Ethernet0/2
 no ip address
 ipv6 address 2001:DB8:0:34::3/64
 ipv6 eigrp 65000
 no shutdown
!
ipv6 router eigrp 65000
 passive-interface default
 no passive-interface Ethernet0/1
 no passive-interface Ethernet0/2
 eigrp router-id 3.3.3.3
!
end

dev4

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
hostname dev4
!
ipv6 unicast-routing
!
interface Ethernet0/1
 no ip address
 ipv6 address 2001:DB8:0:34::4/64
 ipv6 eigrp 65000
 no shutdown
!
interface Ethernet0/2
 no ip address
 ipv6 address 2001:DB8:0:45::4/64
 ipv6 eigrp 65000
 no shutdown
!
ipv6 router eigrp 65000
 passive-interface default
 no passive-interface Ethernet0/1
 no passive-interface Ethernet0/2
 eigrp router-id 4.4.4.4
!
end

dev5

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
hostname dev5
!
ipv6 unicast-routing
!
interface Ethernet0/2
 no ip address
 ipv6 address 2001:DB8:0:45::5/64
 ipv6 eigrp 65000
 no shutdown
!
interface Ethernet0/2
 shutdown
!
!
ipv6 router eigrp 65000
 passive-interface default
 no passive-interface Ethernet0/1
 eigrp router-id 5.5.5.5
!
end

状態確認

dev1

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
dev1# show ipv6 route
IPv6 Routing Table - default - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, HG - NHRP registered
       Hg - NHRP registration summary, HE - NHRP External, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, RL - RPL, O - OSPF Intra, OI - OSPF Inter
       OE1 - OSPF ext 1, OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1
       ON2 - OSPF NSSA ext 2, la - LISP alt, lr - LISP site-registrations
       ld - LISP dyn-eid, lA - LISP away, le - LISP extranet-policy
       lp - LISP publications, ls - LISP destinations-summary, a - Application
       m - OMP
C   2001:DB8:0:1::/64 [0/0]
     via Ethernet0/2, directly connected
L   2001:DB8:0:1::81/128 [0/0]
     via Ethernet0/2, receive
D   2001:DB8:0:12::/64 [90/307200]
     via FE80::A8BB:CCFF:FE00:8C10, Ethernet0/2
D   2001:DB8:0:23::/64 [90/307200]
     via FE80::A8BB:CCFF:FE00:8C10, Ethernet0/2
D   2001:DB8:0:34::/64 [90/332800]
     via FE80::A8BB:CCFF:FE00:8C10, Ethernet0/2
D   2001:DB8:0:45::/64 [90/358400]
     via FE80::A8BB:CCFF:FE00:8C10, Ethernet0/2
L   FF00::/8 [0/0]
     via Null0, receive
1
2
3
4
5
6
dev1# show ipv6 eigrp neighbors
EIGRP-IPv6 Neighbors for AS(65000)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   Link-local address:     Et0/2                    12 00:40:34 1599  5000  0  7
    FE80::A8BB:CCFF:FE00:8C10